/chromebook/community?hl=en
/chromebook/community?hl=en
9/21/16
Original Poster
ZippyDan

SOLVED :Chromebook: WiFi "turned off" / "disabled" - no way to turn on / enable

So, I had this problem with an HP Chromebook the past weekend.  I ran across these threads with similar problems:
 
 
I'm not 100% sure all these problems are the same as mine.  In my situation, I performed an update of the ChromeOS on a ChromeBook that had not been updated in at least a year.  After rebooting from the update, the ChromeBook showed the WiFi as "turned off" (with an "X" through the WiFi symbol) and there was absolutely no way to turn it back on neither on the taskbar nor in the Settings (nor Advanced Settings) panel.
 
I tried doing a Powerwash twice as well as a full USB restore and still could not fix the WiFi problem.
 
Solution: I was finally able to fix the problem in a surprisingly simple (but not necessarily free) manner.  I bought a cheap, generic USB-to-Ethernet adapter.  My plan was to get the ChromeBook connected to the Internet and see if there were possibly any additional ChromeOS updates or patches that might possibly fix the problem.  But that plan turned out to be unnecessary.  As soon as I plugged the USB-to-Ethernet adapter into the ChromeBook's USB slot, and the ChromeBook recognized the additional network connection, the WiFi connection also suddenly turned on as well.  Sincé then, I havent had any problems with the WiFi connection.
 
I would have posted this solution to one of the posts I linked above, but all the google forum posts seem to be locked already.  I wanted to share this experience with you, my anonymous Internet friends, in the hopes that it might save someone some time and/or frustration.
 
Of course, no guarantee this will work for you, because there's no guarantee your problem is the exact same as mine, but it is something to try at least if your symptoms are similar.
 
For anyone running across this post, here are some other solutions you can try:
  1. Restart your ChromeBook (obviously)
  2. Reset your Router (why not?)
  3. Make sure your ChromeBook is fully updated (hard to do without WiFi; see step 7.)
  4. Perform "Hard Reset" (instructions below in the thread)
  5. Login to your ChromeBook as Guest
  6. Perform a PowerWash (restores your ChromeBook to Factory defaults)
  7. Try plugging in a USB-to-Ethernet adapter
 
Community content may not be verified or up-to-date. Learn more.
Recommended Answer
Was this answer helpful?
How can we improve it?
All Replies (39)
Gerald Clark
9/21/16
Gerald Clark
Did you reset your router?
Try to connect as guest.
Try to connect at a free WiFi connection location such as a restaurant.
Do any of these work?
9/21/16
Original Poster
ZippyDan
I feel like you didn't even read the content of my post. :P
  1. My problem is already solved, so I'm not sure why you are suggesting solutions, but thanks anyway.  I'm just trying to share a solution that worked for me with others that might have the same problem.
  2. Resetting my router doesn't really make sense: the WiFi was showing as "turned off".  It's not that I couldn't see my specific WiFi, it's that there was no WiFi funcionality at all on the ChromeBook.  While using my phone or tablet, from the same physical location I was able to detect at least 30 other SSIDs from neighbors.  The ChromeBook couldn't see any WiFi networks at all, because, again, the WiFi was completely disabled.
  3. Connect as a guest to what?
  4. What would connecting to a free WiFi accomplish?  See 3.  I couldn't pick up any WiFi signals in an área with at least 30 active SSIDs, because the WiFi was turned off, so I wouldn't have been able to connect to a free/public WiFi either.
F Noltie
9/21/16
F Noltie
Hi Dan,

Thanks for posting your solution. Maybe/Hopefully it will be useful to others. 🙂

Fred

Gerald Clark
9/21/16
Gerald Clark
I wonder if a Hard reset would have fixed it.
9/21/16
Original Poster
ZippyDan
it was an HP-Brand ChromeBook (not sure of the model right now off-hand) so I don't see the procedure for that specific brand in that list.  That said, I did try powering the machine down completely and removing the power adapter for about an hour.  The battery is not removable unfortunately. 
33 MORE
kenilchattiero
7/13/17
kenilchattiero
I don't have a USB-Ethernet adapter, but I have a smartphone that does tether as " Ethernet connection" via usb, connecting the phone I can get internet via tethering but the wifi does not turn on. 

Should I buy the USB-Ethernet adapter to give one more try?
 
This question is locked and replying has been disabled. Still have questions? Ask the Help Community.

Badges

Some community members might have badges that indicate their identity or level of participation in a community.

 
Google Employee — Google product team members and community managers
 
Community Specialist — Google partners who help ensure the quality of community content
 
Platinum Product Expert — Community members with advanced product knowledge who help other Google users and Product Experts
 
Gold Product Expert — Community members with in-depth product knowledge who help other Google users by answering questions
 
Silver Product Expert — Community members with intermediate product knowledge who help other Google users by answering questions
 
Product Expert Alumni — Former Product Experts who are no longer members of the program
Community content may not be verified or up-to-date. Learn more.

Levels

Member levels indicate a user's level of participation in a forum. The greater the participation, the higher the level. Everyone starts at level 1 and can rise to level 10. These activities can increase your level in a forum:

  • Post an answer.
  • Having your answer selected as the best answer.
  • Having your post rated as helpful.
  • Vote up a post.
  • Correctly mark a topic or post as abuse.

Having a post marked and removed as abuse will slow a user's advance in levels.

View profile in forum?

To view this member's profile, you need to leave the current Help page.

Report abuse in forum?

This comment originated in the Google Product Forum. To report abuse, you need to leave the current Help page.

Reply in forum?

This comment originated in the Google Product Forum. To reply, you need to leave the current Help page.