/chrome/community?hl=en
This content is likely not relevant anymore. Try searching or browse recent questions.
-
7/7/19
Chrome won't load under new Mac Catalina beta 0 Recommended Answers 32 Replies 155 Upvotes
1 Recommended Answer
$0 Recommended Answers
I just installed the Mac OS Catalina beta. Chrome was acting oddly after the install - not connecting with some site and services - so I deleted it and reinstalled it. The download wouldn't run because the system considers it to be unsigned, but it installed after I overrode the security restrictions. Upon starting Chrome, however, I receive a message that the application's integrity cannot be verified and my only options at that point are to cancel the application or move it to the trash. I'd be grateful for any ideas on resolving this issue.

Thanks.
All Replies (32)
7/7/19
I have the same problem on Beta 2. The signature seems fine.

[Edit: I had to trim the code sign output since it seems to somehow violate "Community Policy"? Go figure. Maybe it doesn't like the paths and tildes. Nope. Maybe the hashes? Yup. Bad design, Google.]

Executable=/Users/remaker/Downloads/googlechromeprod.dmg
Identifier=GoogleChrome-75.0.3770.100-GGRO
Format=disk image
CodeDirectory v=20200 size=319 flags=0x0(none) hashes=1+6 location=embedded
Hash type=sha256 size=32
[hashes elided]
Signature size=8961
Authority=Developer ID Application: Google, Inc. (EQHXZ8M8AV)
Authority=Developer ID Certification Authority
Authority=Apple Root CA
Timestamp=Jun 17, 2019 at 6:12:32 PM
Info.plist=not bound
TeamIdentifier=EQHXZ8M8AV
Sealed Resources=none
Internal requirements count=1 size=108

So the chain leads to the Apple Root CA, I'm not sure what the issue is. Catalina bug?
Last edited 7/7/19
marked this as an answer
Helpful?
7/9/19
If you guys right click on chrome and then press open it'll allow you to open it, its a small process but it works
marked this as an answer
Helpful?
7/11/19
Guys.  Apple has screwed Google.  Plain and simple.  Since when has google become an unknown requiring security action on your part ti install.  Yes you can reinstall but it will only work for a few minutes then rejects all sites again.  Oh, and did you know that you now have to go into security settings and under privacy set permissions for chrom to record the mac screen?  Bet you didn’t.  Same goes with splashtop streamer if anyone using it has had problems under catalina.

I am a apple beta tester and they didn’t even bother to tell us what they had changed.  Catalina is a long ways from being ready forr prime time.
marked this as an answer
Helpful?
7/17/19
I've had the same issue. Easily solved. Download the latest version of Chrome. Install it and open it. Do NOT put it into the bin. Just close the error box. Then follow these steps:

System Preferences -> Security & Privacy -> General tab -> Under "Allowed apps download from" you should have a message saying that you've tried opening Chrome. There should be a button saying "Open Anyway". 

This should then open Chrome browser. Click on the notification to allow it to always open.
marked this as an answer
Helpful?
7/17/19
That’s seems to be a great solution. Just trying it, seems to be working let’s see!
Many thanks again
marked this as an answer
Helpful?
7/17/19
I do not see an option for "Allowed apps download from" in the "General" tab of "Security & Privacy" as used to appear in the previous beta releases of MacOS. Any help will be appreciated. This is so frustrating!
marked this as an answer
Helpful?
7/20/19
I had a similar problem with Chrome after the latest Catalina Beta release. I have had some success by using the beta version of Chrome (https://www.google.com/chrome/beta/).
Last edited 7/20/19
marked this as an answer
Helpful?
7/22/19
None of the above steps work!
Any one has a solution, please share. it's so frustrating, trust me!!
marked this as an answer
Helpful?
7/29/19
I have installed the beta from google chrome and it's like adam@kingdevs.io said. 
It works for me. :)

Credits to Adam
marked this as an answer
Helpful?
10/24/19
Same issue - I am able to load it through terminal in super-user mode: 
sudo /Applications/Google\ Chrome.app/Contents/MacOS/Google\ Chrome
Everything is functional, but annoying to have to open it this way. 

I points to this issue though: 
Keystone Registration framework cannot obtain the ticket store path. Falling back to passing: '--user-store', which may not work on older ksadmin versions. Error: <KSError:0x7ff40b5f0c80
domain="com.google.Keystone.SharedErrorDomain"
code=1001
userInfo={
NSLocalizedDescription = "KSPaths accessing user domain ticket store as root.";
line = 291;
filename = "KSPaths.m";
function = "+[KSPaths userTicketStorePathWithError:]";
date = 2019-10-24 20:09:38 +0000;
}


Any thoughts what this issue is?
marked this as an answer
Helpful?
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
Delete post?
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
/chrome/threads
//accounts.google.com/ServiceLogin
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Deleted
Unable to delete reply.
Removed from Answers
Marked as Recommended Answer
Removed recommendation
Undo
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Locked
Unlocked
Unable to lock
Unable to unlock
Pinned
Unpinned
Unable to pin
Unable to unpin
Marked
Unmarked
Unable to mark
Reported as off topic
/chrome/profile/0?hl=en