/chrome/community?hl=en
This content is likely not relevant anymore. Try searching or browse recent questions.
-
Initial lag when starting to scroll with hardware acceleration enabled 0 Recommended Answers 6 Replies 118 Upvotes
1 Recommended Answer
$0 Recommended Answers
1 Relevant Answer
$0 Relevant Answers
I am on the latest MacBook Pro from 2019 and MacOS. With hardware acceleration enabled, there is an initial lag/delay when I scroll if I haven't scrolled for ~5-10 seconds. After that, it's fine. But every time I scroll after being idle, it lags.

If I disable hw acceleration, this symptom no longer occurs.

Any way to fix this without disabling hw acceleration?
Most Relevant Answer Most Relevant Answers (0)
All Replies (6)
Most Relevant Answer
I also ran into this issue with a 2019 15" mbpro. It seems to boil down to the "automatic graphics switching" option in macos's Energy Saver preferences. When this is turned on and I'm on battery, Chrome appears briefly frozen on the first scroll gesture after no user interaction for ~5 seconds or so. Safari and Firefox do not exhibit this behavior.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
I'm also running into the issue exactly as described by @Marius.
2019 Macbook Pro 15"

macOS Mojave
10.14.6 (18G87)

Chrome
Version 76.0.3809.100 (Official Build) (64-bit)
marked this as an answer
Most relevant based on info available
Most Relevant Answer
I am running into the exact same issue on my HP Envy 17.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
This most likely has to do with systems that have a dual graphics chip configuration, usually laptops.

The systems are designed to use the light-weight APU GPU whenever possible to reduce system overhead and lengthen battery time, so when the screen is static and no activity is happening in Chrome, the system will revert down to the integrated APU's graphics engine.

Then when you begin scrolling again, Chrome begins making calls that the system directs to the discrete GPU for hardware acceleration.

The delay being observed is the hand-off time from the APU Graphics to the GPU graphics engines.  This isn't a bug in Chrome, but rather a side-effect of the dual-GPU design in laptops for power-saving.  If you're experiencing this, you can either disable hardware acceleration in Chrome (should be fine in a vast majority of cases) or examine your system's power/performance settings to see if you can disable the APU graphics engine and force all graphics calls to be elevated to the discrete GPU instead.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
I have same problem. Mac OS Catalina, Chrome 78.0.3904.108
This is bug in chrome, because scroll in other browsers working correctly.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
To stop the initial scroll lag caused by the graphics switching between GPUs try the following (in Windows 10). You can still leave hardware acceleration on in Chrome but just fix the system to one graphics card. To do this, type or search "display settings" from the start menu (or right click the desktop and select it). Then at the bottom select "Graphics settings". I used  the "Classic app" setting and browsed for Chrome in program files. Then I changed the options from "System default" to "Power saving" though you can try "High performance" if you like but my Intel 630 integrated GPU was able to drive video in 4K at 60 fps no problem so did not need to use the high performance nvidia GPU. This should give smooth video with hardware acceleration but stop the initial scroll lag. However, It may not stop other forms of scroll lag. You may also be able to assign a specific GPU to an app using other Intel or nvidia apps under Control Panel.
marked this as an answer
Most relevant based on info available
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
Delete post?
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
Report post
What type of post are you reporting?
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
/chrome/threads
//accounts.google.com/ServiceLogin
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Deleted
Unable to delete reply.
Removed from Answers
Marked as Recommended Answer
Removed recommendation
Undo
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Locked
Unlocked
Unable to lock
Unable to unlock
Pinned
Unpinned
Unable to pin
Unable to unpin
Marked
Unmarked
Unable to mark
Reported as off topic
/chrome/profile/0?hl=en