This content is likely not relevant anymore. Try searching or browse recent questions.
Why page translating google translate not working on chrome android ? 0 Recommended Answers 19 Replies 28 Upvotes
1 Recommended Answer
$0 Recommended Answers
This morning googIe translate still working to translate chinesse website, then at afternoon, I translate again that website and its not working, I have tried the chrome to close and open again, update it, restart my phone, clear the cookies. Its not only that website, other website too. I try to change to other languages, still not working. 
All Replies (19)
google sucks, they wont let me translate the pages too, i still need to go to google translate and paste the link. so annoying
marked this as an answer
any resolution to this issue? It's been ongoing for some time now.
marked this as an answer
just right click on page  > translate
marked this as an answer
noe of this bs works they need to fix this shit , they always massing things up fix this crap now goolge!!!!!!!!!!!!!!!!!
marked this as an answer
I also have tried all the suggestions for how to fix the problem. Refreshed, cleared cache and cookies, went to settings and advanced language settings and turned on and turned off the "offer to translate page in language I don't read" several times. Nothing worked. If this is a google issue, Google please fix the problem. This has been going on for a while now.
Last edited 9/17/19
marked this as an answer
I have the same problem.    Google Translate worked yesterday and now, no matter what I do, doesn't work...  Grrrr!
marked this as an answer
Same problem: no longer able to translate email. How can a person read and respond without this translation?
marked this as an answer
Suggested solution which worked today for me: 

Not sure if it will continue to work or if it works for every scenario
marked this as an answer
I'm facing also the same issue.
I tried a lot of ways to fix but couldn't. 

But one trick works for me though it's annoying.
- Go to the options from the popup
- Change the from language (In my case it was English to English).
marked this as an answer
This reply is no longer available.
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
Delete post?
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Unable to delete reply.
Removed from Answers
Marked as Recommended Answer
Removed recommendation
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Unable to lock
Unable to unlock
Unable to pin
Unable to unpin
Unable to mark
Reported as off topic