/chrome/community?hl=en
This content is likely not relevant anymore. Try searching or browse recent questions.
-
4/15/19
Windows 10 Computers Suddenly Can't Print from Chrome Browser 0 Recommended Answers 41 Replies 112 Upvotes
1 Recommended Answer
$0 Recommended Answers
Last edited 6/28/19
I work in a school where all machines are Windows 10 and all default browsers are Google Chrome.  There are several different copiers ranging from Dell laser printers to Ricoh copiers with printing.  All of a sudden about a month ago, the staff came in and 3 people were not able to print from Chrome.  

This applies to anything you attempt to print from the Chrome browser i.e. single pictures, an email, a web page, a pdf.  The printers are connected and active.  When print or CTRL+P is pressed, the print dialog comes up, but the preview in the main right panel doesn't draw/render and the options to set up the print in the left panel are greyed out.  

Then over the course of the last few weeks, a domino effect of almost every other computer in the school started exhibiting the same behavior.  There are a few left that will print successfully, but most are doing the same exact thing.

A few details:
- This is exclusive to the Chrome browser.  MS Office, Adobe Reader, Photo apps, etc... all print normally.
- This is not through Google Cloud Print, but standard print drivers setup, tested, updated, and reinstalled with the same behavior.  I know of Google  Cloud Print and while it may be necessary to go in that direction, it never was before about a month ago as everything has been printing from Chrome fine with the regular printer drivers.  We have one printer capable of Google Cloud print, but the others which are the ones used for the bulk of staff print jobs are not.

The steps I've taken:
- Checked for Windows updates
- Checked for Chrome updates
- Uninstalled all standalone Shockwave and Flash installations
- Checked for printer driver updates, deleted and reinstalled printer drivers
- Uninstalled and reinstalled the printers themselves
- Power cycled printers and computers
- Tried the Ricoh print for Chrome extension.  Same failed result.
- Cleared the Chrome cache and reset settings to default.
- Uninstalled all Chrome extensions.
- Uninstalled and reinstalled Chrome.
- Called the copier company's tech support who said there is nothing on the end of their copiers that could be causing this.

I'm at a loss here as this is a non-stop series of complaints and help requests over this issue daily for weeks now.  Is there some known issue that could be causing this?  Something in a recent update?  Any hope for a fix?

I did try to search for a solution online before posting this.  Most were very outdated and the one I saw that was current didn't have any results.  My apologies if there is a fix already posted somewhere and if so, please point me in that direction.
All Replies (41)
4/16/19
Me too I have the same problem and still can't print.
marked this as an answer
Helpful?
4/20/19
Same here!  I can print from Firefox, but not Chrome.  Did all the steps you did as well.  Frustrating.  Problem just happened out of the blue.  I have searched for online answers as well, no luck.  For me, I am going to switch default browser to Firefox for now.
marked this as an answer
Helpful?
4/24/19
I am having the same problem printing from Chrome.  No other Browser is posing a problem to print.  We are a school as well and we use Chrome as our default browser.  Help!
marked this as an answer
Helpful?
4/25/19
I also am having the same issue. The print button will often be greyed out. My users have resorted to saving pages as PDFs or using Internet Explorer.

They would like to use Chrome, but cannot because of the inconsistent experience in Chrome.
marked this as an answer
Helpful?
5/3/19
I'm having the same issue, also in a school. If we download a doc, open it in PDF viewer/word etc it prints fine, but from Chrome it doesn't even arrive at the print queue.
marked this as an answer
Helpful?
5/5/19
I'm have the same issues... went back to FireFox!
marked this as an answer
Helpful?
5/6/19
I cannot believe this has NOT been resolved yet!!!
marked this as an answer
Helpful?
5/7/19
cannot print also all of a sudden on Chrome only....why isn't something being done about this?
marked this as an answer
Helpful?
5/9/19
Add me to the list of folks who cannot print and who have tried EVERY fix I can as a non-techie, home-based freelancer. I have spent hours trying to fix this. If I didn't have so many bookmarks in Chrome, I'd dump it and use Edge or Firefox, where I have no issues printing. 

It happened once, and I was able to fix it. Then there was a windows update, and it came back. I can't control Windows or Google, I feel completely unheard by either platform.

COME ON GOOGLE, fix this issue!!!
marked this as an answer
Helpful?
8/6/19
Same issue:  Not EXACTLY sure what I did that fixed it but... one thing was 

Settings
Reset and Clean up in the settings.    
I re-selected my printer and now it works.
marked this as an answer
Helpful?
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
Delete post?
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
/chrome/threads
//accounts.google.com/ServiceLogin
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Deleted
Unable to delete reply.
Removed from Answers
Marked as Recommended Answer
Removed recommendation
Undo
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Locked
Unlocked
Unable to lock
Unable to unlock
Pinned
Unpinned
Unable to pin
Unable to unpin
Marked
Unmarked
Unable to mark
Reported as off topic
/chrome/profile/0?hl=en