/chrome/community?hl=en
This content is likely not relevant anymore. Try searching or browse recent questions.
This post is a trending issue.
-
GPG Key error debian repo for chrome 2 Recommended Answers 74 Replies 725 Upvotes
1 Recommended Answer
$0 Recommended Answers
Hi,

we seem to be getting a GPG key errors when trying to install chrome for our debian docker image using apt

https://dl.google.com/linux/linux_signing_key.pub 

https://dl.google.com/linux/chrome/deb/ seems to be giving us a GPG error

W: GPG error: http://dl.google.com/linux/chrome/deb stable Release: The following signatures were invalid: EXPKEYSIG 1397BC53640DB551 Google Inc. (Linux Packages Signing Authority) <linux-packages-keymaster@google.com>

E: The repository 'http://dl.google.com/linux/chrome/deb stable Release' is not signed.

Thanks
Steven
All Replies (74)
marked this as an answer
apt-key list shows that the "latest" Linux package signing key with fingerprint 4CCA 1EAF 950C EE4A B839  76DC A040 830F 7FAC 5991 dates from 2007-03-08. I'm pretty sure there have been more recent keys than that. Is time going backwards?
marked this as an answer
reported in Debian Sid
W: Erreur de GPG : http://dl.google.com/linux/chrome/deb stable Release : Les signatures suivantes ne sont pas valables : EXPKEYSIG 1397BC53640DB551 Google Inc. (Linux Packages Signing Authority) <linux-packages-keymaster@google.com>
marked this as an answer
Ditto repo: "deb http://dl.google.com/linux/earth/deb/ stable main "

GPG error: http://dl.google.com/linux/earth/deb stable Release: The following signatures were invalid: EXPKEYSIG 1397BC53640DB551 Google Inc. (Linux Packages Signing Authority) <linux-packages-keymaster@google.com>, E:The repository 'http://dl.google.com/linux/earth/deb stable Release' is not signed.

This started shortly after the last Google Earth update (Version 7.3.2.5776 ) on Tuesday, March 5.
marked this as an answer
Same to me too

Errore:17

And here where the GPG are giving error
: Si è verificato un errore nel verificare la firma. Il repository non è aggiornato e verranno usati i file indice precedenti. Errore GPG: http://dl.google.com/linux/chrome/deb stable Release: Le seguenti firme non erano valide: EXPKEYSIG 1397BC53640DB551 Google Inc. (Linux Packages Signing Authority) <linux-packages-keymaster@google.com>
W: Impossibile recuperare http://dl.google.com/linux/chrome/deb/dists/stable/Release.gpg  Le seguenti firme non erano valide: EXPKEYSIG 1397BC53640DB551 Google Inc. (Linux Packages Signing Authority) <linux-packages-keymaster@google.com>
marked this as an answer
Report @ Deb Stable when running $ apt update
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://dl.google.com/linux/chrome/deb stable Release: The following signatures were invalid: EXPKEYSIG 1397BC53640DB551 Google Inc. (Linux Packages Signing Authority) <linux-packages-keymaster@google.com>

W: Failed to fetch http://dl.google.com/linux/chrome/deb/dists/stable/Release.gpg  The following signatures were invalid: EXPKEYSIG 1397BC53640DB551 Google Inc. (Linux Packages Signing Authority) <linux-packages-keymaster@google.com>

W: Some index files failed to download. They have been ignored, or old ones used instead.


$ apt-key list
sub   dsa1024 2007-03-08 [SC]                           
      4CCA 1EAF 950C EE4A B839  76DC A040 830F 7FAC 5991                                         
uid           [ unknown] Google, Inc. Linux Package Signing Key <linux-packages-keymaster@google.com>
sub   elg2048 2007-03-08 [E]     


/etc/apt/souce.list.d/google-chrome.list
deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
marked this as an answer
apt update on Ubuntu 16.04.6 :

Ign :11 http://dl.google.com/linux/chrome/deb stable Release.gpg             
Lecture des listes de paquets... Fait
W: Erreur de GPG : http://dl.google.com/linux/chrome/deb stable Release : Les signatures suivantes ne sont pas valables : KEYEXPIRED 1555048520  KEYEXPIRED 1555048520  KEYEXPIRED 1555048520  KEYEXPIRED 1555048520
E: Le dépôt http://dl.google.com/linux/chrome/deb stable Release n'est pas signé.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
marked this as an answer
Same thing on Linux Mint 19.1:

​W: Failed to fetch http://dl.google.com/linux/chrome/deb/dists/stable/Release.gpg  The following signatures were invalid: EXPKEYSIG 1397BC53640DB551 Google Inc. (Linux Packages Signing Authority)
W: Some index files failed to download. They have been ignored, or old ones used instead.
marked this as an answer
The latest public Linux signing key file from dl.google.com appears to match the details shown on https://www.google.com/linuxrepositories/ 
However, it appears that the Release file for the apt repository is not signed with that key. Perhaps this was by mistake.
$ wget -q https://dl-ssl.google.com/linux/chrome/deb/dists/stable/Release.gpg
$ gpg --no-default-keyring --keyring linux_signing_key.pub --verify Release.gpg Release
gpg: Signature made Wed 10 Apr 2019 01:12:23 PM CDT
gpg:                using RSA key 1397BC53640DB551
gpg: Can't check signature: No public key
$ gpg --dearmor ./linux_signing_key.pub
$ gpg --list-keys --no-default-keyring --keyring ./linux_signing_key.pub.gpg 
./linux_signing_key.pub.gpg
---------------------------
pub   dsa1024 2007-03-08 [SC]
      4CCA1EAF950CEE4AB83976DCA040830F7FAC5991
uid           [ unknown] Google, Inc. Linux Package Signing Key <linux-packages-keymaster@google.com>
sub   elg2048 2007-03-08 [E]

pub   rsa4096 2016-04-12 [SC]
      EB4C1BFD4F042F6DDDCCEC917721F63BD38B4796
uid           [ unknown] Google Inc. (Linux Packages Signing Authority) <linux-packages-keymaster@google.com>
sub   rsa4096 2017-01-24 [S] [expires: 2020-01-24]
marked this as an answer
Oops, I made a mistake in my previous post (and attempting to edit it fails -- says that I am "violating community policy" though I don't believe that I am). When verifying the signature with gpg, you need to use the dearmored (binary, not text) version of the public key:

$ gpg --no-default-keyring --keyring ./linux_signing_key.pub.gpg --verify Release.gpg Release
gpg: Signature made Wed 10 Apr 2019 01:12:23 PM CDT
gpg:                using RSA key 1397BC53640DB551
gpg: Good signature from "Google Inc. (Linux Packages Signing Authority) <linux-packages-keymaster@google.com>" [unknown]
gpg: Note: This key has expired!
Primary key fingerprint: EB4C 1BFD 4F04 2F6D DDCC  EC91 7721 F63B D38B 4796
     Subkey fingerprint: 3B06 8FB4 789A BE4A EFA3  BB49 1397 BC53 640D B551

Closer investigation shows that the subkey expired today:
gpg --list-keys --list-options show-unusable-subkeys --no-default-keyring --keyring ./linux_signing_key.pub.gpg 
./linux_signing_key.pub.gpg
---------------------------
pub   dsa1024 2007-03-08 [SC]
      4CCA1EAF950CEE4AB83976DCA040830F7FAC5991
uid           [ unknown] Google, Inc. Linux Package Signing Key <linux-packages-keymaster@google.com>
sub   elg2048 2007-03-08 [E]

pub   rsa4096 2016-04-12 [SC]
      EB4C1BFD4F042F6DDDCCEC917721F63BD38B4796
uid           [ unknown] Google Inc. (Linux Packages Signing Authority) <linux-packages-keymaster@google.com>
sub   rsa4096 2016-04-12 [S] [expired: 2019-04-12]
sub   rsa4096 2017-01-24 [S] [expires: 2020-01-24]
marked this as an answer
Hi, Is this problem occurring, do you know the reason?

"GPG error: http://dl.google.com/linux/chrome/deb stable Release: The following signatures were invalid: KEYEXPIRED 1555048520 KEYEXPIRED 1555048520 KEYEXPIRED 1555048520 KEYEXPIRED 1555048520W: The repository 'http://dl.google.com/linux/chrome/deb stable Release' is not signed. [0mWARNING: The following packages cannot be authenticated! google-chrome-stable"

Thanks.
marked this as an answer
Same problem in Linux Mint XFCE 19.1 !
marked this as an answer
"The following signatures were invalid: EXPKEYSIG 1397BC53640DB551 ​​Google Inc." at
marked this as an answer
For anyone not patient enough for google to update cert...
you can fix this with the following steps :
I got the same today.
here's what you do:
  1. Download this : https://dl.google.com/linux/direct/google-chrome-stable_current_amd64.deb
(chrome new version, you can get it yourself by googling chrome)
  1. Close Chrome.
  2. Open "Software and Sources", go to the "Sources" tab
  3. Remove (or disable if you wish to re-enable it at a later time) the Google source (type your password) and close the window
  4. Allow "Software and Sources" to reload sources
  5. Go into Software Center, go to "Installed"
  6. Find Chrome, uninstall it.
  7. Close software and sources
  8. Open a terminal, type :
    sudo apt update && sudo apt autoremove -y && sudo apt autoclean && sudo apt full-upgrade -y
  9. Close the terminal and go to your downloads folder and double click the file "google-chrome-stable_current_amd64.deb" (this will open Software Center)
  10. Click Install
you can now open chrome back up. all your tabs and saved passwords ect are still there.
marked this as an answer
But that doesn't solve the repository problem... :)
marked this as an answer
Same happens to me:
W: Error de GPG: http://dl.google.com/linux/chrome/deb stable Release: Las siguientes firmas no fueron válidas: EXPKEYSIG xxxxxxxxxxxxxxx Google Inc. (Linux Packages Signing Authority) <linux-packages-keymaster@google.com>
E: El repositorio «http://dl.google.com/linux/chrome/deb stable Release» no está firmado.
marked this as an answer
Hey all,

Thanks for helping bring this to our attention. Our team is aware and investigating the reported behavior.

You can follow along for updates on our public Chromium bug tracker:

Note: As usual, we ask that you only comment on the bug tracker if you have specific debugging information to contribute.

Thanks again!
marked this as an answer
Don't do that huge adventure above, it changes way more than necessary. Instead, you can just run these commands: 
wget https://dl.google.com/linux/direct/google-chrome-stable_current_amd64.deb
sudo dpkg -i ./google-chrome-stable_current_amd64.deb
sudo apt-get install -f
marked this as an answer
Looks like it's been fixed.
marked this as an answer
It's fixed for chrome, but it's still an issue for google earth repo.

W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://dl.google.com/linux/earth/deb stable Release: The following signatures were invalid: EXPKEYSIG 1397BC53640DB551 Google Inc. (Linux Packages Signing Authority) <linux-packages-keymaster@google.com>
W: Failed to fetch http://dl.google.com/linux/earth/deb/dists/stable/Release.gpg  The following signatures were invalid: EXPKEYSIG 1397BC53640DB551 Google Inc. (Linux Packages Signing Authority) <linux-packages-keymaster@google.com>
W: Some index files failed to download. They have been ignored, or old ones used instead.
marked this as an answer
There working on the other repositories as we write.
marked this as an answer
marked this as an answer
yes now an apt update says that there are no problems? but it looks weird: All packages updated. Yes so far so good. But:

 apt-key list Google
pub   rsa4096 2016-04-12 [SC]
      EB4C 1BFD 4F04 2F6D DDCC  EC91 7721 F63B D38B 4796
uid           [    okänt    ] Google Inc. (Linux Packages Signing Authority) <linux-packages-keymaster@google.com>
sub   rsa4096 2017-01-24 [S] [går ut: 2020-01-24]

pub   dsa1024 2007-03-08 [SC]
      4CCA 1EAF 950C EE4A B839  76DC A040 830F 7FAC 5991
uid           [    okänt    ] Google, Inc. Linux Package Signing Key <linux-packages-keymaster@google.com>
sub   elg2048 2007-03-08 [E]

as i read this: the 5991 key is expired but ubuntu doesnt care...........does it use 4796 perhaps?
marked this as an answer
This reply is no longer available.
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
Delete post?
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
Report post
What type of post are you reporting?
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
/chrome/threads
//accounts.google.com/ServiceLogin
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Deleted
Unable to delete reply.
Removed from Answers
Marked as Recommended Answer
Removed recommendation
Undo
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Locked
Unlocked
Unable to lock
Unable to unlock
Pinned
Unpinned
Unable to pin
Unable to unpin
Marked
Unmarked
Unable to mark
Reported as off topic
/chrome/profile/0?hl=en