/chrome/community?hl=en
This content is likely not relevant anymore. Try searching or browse recent questions.
I cannot switch input mode between Chinese and English by pressing the "Left shift" key. 0 Recommended Answers 13 Replies 42 Upvotes
1 Recommended Answer
$0 Recommended Answers
1 Relevant Answer
$0 Relevant Answers
I am a Chinese user on Ubuntu 19.10, and I am using ibus Chinese (boshiamy-t) as my input method. Since Chrome updated to version 79, I cannot switch the input mode between Chinese and English by just pressing the "Left shift" key as before. 
 
I think that it is an issue of Chrome since I've tested the functionality of the "Left shift" key of Chinese (boshiamy-t) on other applications like Firefox and Text Editor and it works on them. Now, every time when I need to type some English words in the Chinese (boshiamy-t) input method, I have to press "win"+"space" to change my input method to English input method. It is really inconvenient for me.  My Chrome version now is  79.0.3945.88 (Official Build) (64-bit).

Is there any Chinese user having the same problem like me?
Relevant Answer Relevant Answers (0)
All Replies (13)
Relevant Answer
Using Korean and the same problem occurs.

Using "Alt-R" for toggling "Hangul" (Korean) but it doesn't work. Works PERFECTLY FINE with rest of apps on Ubuntu 19.10; VSCode, terminal, Firefox, etc. But doesn't work only on chrome 79.

Tried to downgrade chrome which wouldn't work, so I don't know how to fix this on my own.

I am able to type Korean by manually changing to Hangul mode which is super annoying.

I don't know if this is problem with Ubuntu or chrome, but I did upgrade to version 79 while I was on Ubuntu 19.04 then upgraded to 19.10 a few days later hoping that Ubuntu upgrade fixes the problem.

An entry from `/var/log/apt/history` log file says that I upgraded from 78.0.3904: google-chrome-stable:amd64 (78.0.3904.108-1, 79.0.3945.88-1)

Tried with chrome Beta version 80 and the problem still persisted.

Please help
marked this as an answer
Relevant Answer
Same problem here. I'm also using right alt key for switching Hangul/English.
I'm using Ubuntu 19.10, and there was no problem before chrome update.
I guess this is problem with Chrome, and please fix this or I'll be moving to Firefox..

Edit: I tried to change the input switching key to shift+space, and the problem is solved.
It seems Chrome overrides right alt key for its shortcuts.
marked this as an answer
Relevant Answer
Same problem
marked this as an answer
Relevant Answer
The same on 1804, it is just occured on chrome, also chromium, but works well on other applications. ps, I am using ibus Chinese(Wubixxx). I've tried to switch to fcitx, it works...
marked this as an answer
Relevant Answer
Same problem, too
marked this as an answer
Relevant Answer
same problems i have in chrome on linux(ubuntu 18.04) when i using korean. 
As the person mentioned eariler, language switching is impossible, in only chrome. 
you should fix as soon as possible, i think.
marked this as an answer
Relevant Answer
It has been working while I was using version 72, and the problem started ever since I updated to 80. So... it's been a month ever since the bug was reported and not yet fixed? What is the point of releasing the 'buggy' update while not allowing access to the older versions?
marked this as an answer
Relevant Answer
After upgrading chrome to #80, right alt key has not been working for switching languages with iBUS.
As the other user mentioned previously, changing to SHIFT+SPACE could solve the problem. But it's a little annoying.
I hope this issue could be solving in near future.
marked this as an answer
Relevant Answer
same problem after upgrading chrome to Version 80.0.3987.116 (Official Build) (64-bit)

my os version is Ubuntu 19.10, kernel version is 5.3.0-29-generic

even I changed("ctrl"+"shift") the input method from chinese(ibus-sunpinyin) to English input method. but the input mode still in chinese and I cannot type English words until I use my mouse to change the input mode, however the mode still display in CN for a while(about ~5s) then change to EN.

It seems that the shift key is captured by chrome, therefore note detected by system.

--- 
EDIT: downgrade chrome to a lower version helps, looks like linux version <= 78.0.3904.97  doesn't have this issue.
marked this as an answer
Relevant Answer
Same here. The input mode is bound to the mode when the focus entered chromium. If I wish to switch mode, e.g. from Chinese to English, I have to focus on another app, say terminal emulator, switch mode, then re-enter chromium.

Environment: Version 80.0.3987.87 (Official Build) Built on Ubuntu , running on Ubuntu 18.04 (64-bit) with ibus-sunpinyin
marked this as an answer
Relevant Answer
I have a same problem with Chromium Browser.
Version 80.0.3987.132(공식 빌드) Arch Linux (64bit)
marked this as an answer
Relevant Answer
I tested many times.
I think this is not Chrome's fault.
In Korean laptop keyboard, I checked KeyCodes of Hangul key and Hanja key.
It was right Alt key(0x6c) and right Ctrl key(0x69).
So, I re-mapped keycodes to Hangul and Hangul_Hanja.
And then, everything works well.

If you are a Korean and want to follow me, please view my post.

Good Luck.
marked this as an answer
Relevant Answer
Chrome Version 80.0.3987.149 (Official Build) (64-bit) on Ubuntu 18.04.4, meet the same problem.
marked this as an answer
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
Delete post?
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
Report post
What type of post are you reporting?
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
/chrome/threads
//accounts.google.com/ServiceLogin
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Deleted
Unable to delete reply.
Removed from Answers
Marked as Recommended Answer
Removed recommendation
Undo
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Locked
Unlocked
Unable to lock
Unable to unlock
Pinned
Unpinned
Unable to pin
Unable to unpin
Marked
Unmarked
Unable to mark
Reported as off topic
/chrome/profile/0