/chrome/community?hl=en
This content is likely not relevant anymore. Try searching or browse recent questions.
[SOLVED] [Chrome 78] No #enable-native-notifications flag 0 Recommended Answers 10 Replies 84 Upvotes
1 Recommended Answer
$0 Recommended Answers
1 Relevant Answer
$0 Relevant Answers
I use Tweetdeck and I prefer the Chrome pop-up notifications over the Ubuntu ones (currently 19.10), so I set the #enable-native-notifications flag to "Disabled." 

Come Chrome 78 and this flag is no more. Does that mean I can't enable/disable native notifications anymore or was this setting moved elsewhere?
Relevant Answer Relevant Answers (0)
All Replies (10)
Relevant Answer
I found out the flag is still available; it's just hidden. No idea why, though. Here's the solution:

— Open the terminal, type gedit ~/.config/google-chrome/Local\ State and hit Enter.

— Press Ctrl+H to open the Find and Replace window. In the 1st field, type "tab-hover-cards@4". In the 2nd one, type "enable-native-notifications@2","tab-hover-cards@4" (to disable) or "enable-native-notifications@1","tab-hover-cards@4" (to enable). Then click on "Replace All".

— Save the file and restart Chrome.

marked this as an answer
Relevant Answer
i have a mac computer, located the file but i did not find the lines of code to change
marked this as an answer
Relevant Answer
Same here. I'm running Windows 10, can locate the file, but there's no "tab_hover" at all.
marked this as an answer
Relevant Answer
Ok, here's the REAL steps for you:
  1. CLOSE all instances of Chrome (and if Chrome is still running in the tray when closed, right click on that and choose to Close/Exit)
  2. Open your User Data folder %LocalAppData%\Google\Chrome\User Data\
  3. Open the "Local State" file in a text editor
  4. Find the text "enabled_labs_experiments" (mine looked like this: "enabled_labs_experiments":["load-media-router-component-extension@1"] )
  5. In the array next to it, add (or change) the flag according to Welton's comment (but without the tab-hover part):
    1. TO DISABLE: "enable-native-notifications@2"
    2. TO ENABLE: "enable-native-notifications@1"
  6. It should now look something like this: "enabled_labs_experiments":["load-media-router-component-extension@1", "enable-native-notifications@2"]
  7. Save the file
  8. Start Chrome
  9. Be Happy
(Also, this works for Brave Browser too if you replace the Chrome paths with the Brave ones %LocalAppData%\BraveSoftware\Brave-Browser\User Data\ . Everything else should be the same)
marked this as an answer
Relevant Answer
I was not able to find "enabled_lab_experiments" in my local state folder.
marked this as an answer
Relevant Answer
Derek's solution worked perfectly!

In my case I didn't have the string ["load-media-router-component-extension@1"], so my string ended like this:

"enabled_labs_experiments":["enable-native-notifications@2"]

When I tryed to copy Derek's line ("enabled_labs_experiments":["load-media-router-component-extension@1", "enable-native-notifications@2"]) the Chrome added the extention .bad to the file and it didn't work. Maybe because in my PC I didn't have the Load Media Router Component Extension.

@Eliyas you have to open the "Local State" file. Try to use Visual Studio Code or some code editor, because with Notepad I couldn't find the string.

Thanks to all and regards!
marked this as an answer
Relevant Answer
Same issue as Eliyas. "enabled_lab_experiments" does not exist in the "Local State" file. Does anyone know where it should be added?
marked this as an answer
Relevant Answer
if "enabled_lab_experiments" not exist in the local state file then you need to add them manually

"browser":{"enabled_labs_experiments":["enable-native-notifications@2"],"last_redirect_origin":""},

find the keyword "browser" then add the option
marked this as an answer
Relevant Answer
It's crazy how difficult this is. Most normal users would never figure out how to adjust these settings. The custom notifications / sounds are a better experience than the Windows Notification center.

The only reason I like the old notifications better is because of the sounds. If Google added the ability to customize the alert sounds in the Notification Center, I would be fine.
marked this as an answer
Relevant Answer
Hello,

If "enabled_labs_experiments" does not exist in Local State you can add it by entering to the route:


There, you have to press "Enable native notifications.". In my case I choosed Disabled, but of course it didn't work as well. However, it added the string "enabled_labs_experiments" to the Local State file.

Then, you can modify the Local State file with the solution we posted here.

With regards
marked this as an answer
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
Delete post?
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
Report post
What type of post are you reporting?
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
/chrome/threads
//accounts.google.com/ServiceLogin
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Deleted
Unable to delete reply.
Removed from Answers
Marked as Recommended Answer
Removed recommendation
Undo
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Locked
Unlocked
Unable to lock
Unable to unlock
Pinned
Unpinned
Unable to pin
Unable to unpin
Marked
Unmarked
Unable to mark
Reported as off topic
/chrome/profile/0