/chrome/community?hl=en
This content is likely not relevant anymore. Try searching or browse recent questions.
-
"Always open these types of links in the associated app" checkbox is not displayed 0 Recommended Answers 148 Replies 1489 Upvotes
1 Recommended Answer
$0 Recommended Answers
1 Relevant Answer
$0 Relevant Answers
After clearing out my cache (completely) all my open in app preferences were cleared (expected). However, now when I try to open link such as Quip or Zoom, I get the prompt to open in the correct application, however, it doesn't show the "Always open these types of links in the associated app".

How can I save the preference?
Most Relevant Answer Most Relevant Answers (0)
All Replies (148)
Most Relevant Answer
I'm having this same issue too after having to reinstall chrome. Kinda annoying when playing roblox since i server hop quite alot and the no checkbox thing to have it always open is a pain. It would become habit but maybe google will fix this.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Same issue here. I'm having this issue with Zoom and found this article about the issue: https://support.zoom.us/hc/en-us/articles/203787365-Meeting-Won-t-Launch-from-Google-Chrome

However, when I found the `"protocol_handler"` object in my `Preferences` file, it was blank: `"protocol_handler":{}`. 

I updated it per the article to: `"protocol_handler":{"excluded_schemes":{"zoommtg":true}}`, restarted and tried again with no success. I then checked my `Preferences` file again and the object had been changed to: `"protocol_handler":{"excluded_schemes,*":{"zoommtg":true}}` – note the inclusion of `,*` in the object key.

Version 77.0.3865.90 (Official Build) (64-bit)
macOS 10.14.6
marked this as an answer
Most relevant based on info available
Most Relevant Answer
To those who don't enjoy this new feature:
PLEASE SEND FEEDBACK TO THE CHROME TEAM ABOUT THIS ISSUE VIA CHROME
  • To give feedback, just press ALT+SHIFT+i OR
  • Click the menu button (the three dots in the right top corner) > Help > Report an issue


In Chrome 76.0.3809.132 the 'Always open these types of links in the associated app' box is present.
In Chrome 77.0.3865.90 the 'Always open these types of links in the associated app' box is missing.
Furthermore, if you had previously checked the box, this particular setting is ignored after the upgrade.


As others have mentioned this is an incredibly important option to have, especially in an Enterprise environment.  While I understand the [in]security argument and sympathize with those who chant the "You could be exposed because Chrome opened some random URI/protocol handler" mantra, I think it's important to consider:
  • Chrome doesn't open handlers without expressed permission from the user operating the machine.
  • If the operator checked the box & forgot about it, that's not Chrome's fault.
  • If the operator left the machine unattended and someone else did it, that's also not Chrome's fault
  • It's extremely heavy handed to have a feature, and for such a long time too, then take it away without any sort of notice or equivalent workaround
There are plenty of intelligent user-friendly ways to handle this including but not limited to:
  • Always open these types of links from this website in the associated app
  • Allow an 'enhanced security' mode in Chrome that removes the check box along with a number of other changes to improve the security posture.
  • Adjust the process such that making this change requires more thought like displaying a warning banner or prompt to re-validate this setting once a month or quarter or N period of time.
Ok - I'm off my soap box. :)


marked this as an answer
Most relevant based on info available
Most Relevant Answer
I have the same problem, how can I fix this ?

Where is the checkbox ?
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Hi folks,
 
I'm afraid this is intended and the protocol_handler preferences aren't supported for now. I wrote an update about it in this post:
 
Maybe it helps to send in your feedback directly to the Chrome team:
 
How to give feedback about Chrome:
To give feedback, just press [alt + shift + I] (the I from Issue)
or click the menu button (the three dots in the right top corner) > Help > Report an issue
 
Cor
marked this as an answer
Most relevant based on info available
Most Relevant Answer
I hate to be "that guy," but the two big issues from Chrome 77 (this and the annoying notification every time I boot my PC) is causing me to switch browsers.

I join Zoom meetings 3 - 4 times a day.  This irritating change isn't worth me keeping Chrome as my browser.

Bring back Chrome 76.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Agreed. I'm going to switch to another browser too.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
where is the fix !?
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Taking away options for "Security reason" and not giving the advanced users or enterprise a way to manage their own preferences is why I'll be switching away from the chrome browser.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
agreed. It ain't a good way to treat your users. Here's a workaround:
https://support.google.com/chrome/thread/14194567?msgid=15347344
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Hi Cor,

None of the links you provided above are valid anymore.  I was keeping an eye on those threads, and last time I looked the original bug report had almost 1000 upvotes.  

Do you know why that page has been deleted?  Not even the work around page works now.

Just to confirm, the custom protocol handler we wrote for our software no longer works, and we have 100,000 users of our software.  We'll need to inform them to use another browser if this can't be fixed.  We really don't want to do that.

I'll try logging it directly to the Chrome team as you've mentioned, although I'm pretty confident I'll receive no response.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Why are so many posts related to this missing?  Threads deleted, replies etc....  Its a big issue!
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Uninstall Chrome.

Search for and find the Chrome 76.0.3809.132 offline installer.

Reinstall this version.

Disable updates.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
> Do you know why that page has been deleted?  Not even the work around page works now.

@Click Studio, I'm wondering the same thing.  This is sad.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Moving to firefox until this gets fixed in Chrome.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Moving to Edge till they fix Chrome.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Here comes Google, The dictator!
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Can someone post the workaround in this page? The link does not longer work, thanks!
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Are there plans to implement it again in future versions?
marked this as an answer
Most relevant based on info available
Most Relevant Answer
This is so annoying. I hate the fact that the workaround is to use a different browser.

I forgot how I found this but it may have been posted by a diff person from a diff page but just to help out you can do this on the regedit and follow the topic:


The Policy didn't exist on my regedit so basically you start from HKEY_CURRENT_USER
marked this as an answer
Most relevant based on info available
Most Relevant Answer
I meet this problem in developing web app too.
 i think it's really unfriendly to user
they add a page to manage trusted external protocal
marked this as an answer
Most relevant based on info available
Most Relevant Answer
This is an absolutely terrible design decision.  At least provide some kind of workaround for this.  We make an enterprise application and our users can open our app whenever they click a link in our web app.  Now they have to click the subsequent dialog box every single time that they open our app.  Of course as usual our customers think that it's our bug even though it's Chrome's issue.

This needs to be addressed ASAP.  It used to be that we recommended Chrome because Safari has this same issue.  Now we will recommend Firefox to our users.  If the google team can listen to all of the users here, and fix this issue, we can go back to recommending Chrome.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
I can offer a workaround AND an apparent solution for this problem - the workaround is my own, the solution from someone else.  The solution appears to be a durable one, and I have tested it myself and it works for me!

Workaround:  You can install an old version from before they made this *bad* change, do your checkbox, and then update back into the latest version of chrome.  The setting change you implement with the old version will persist into the new versions.

I keep an old copy of chrome v75.0.3770.80 (offline installer) just for this purpose.

The solution is very flexible/simple.  If you're running a current version and need to implement the checkbox thing, you can just install an old version where that works on top of your current installation -- implement the check box you need -- and then just update to get back to the current version.  None of your other settings/data will be hurt.

There was a time when you could manually edit the preferences file to put in the needed setting.. that no longer seems to work:  only by installing an old version where the check box capability exists and then updating back to current works.


SOLUTION:  Apparently you can "whitelist" your protocol handler via a windows registry entry so chrome won't bitch about it.  Here is that solution:

https://t-e.cc/google-chrome-no-longer-displays-always-open-these-types-of-links-in-the-associated-app-checkbox-fix/


Disclaimer:  the above worked for me, your mileage may vary.  Thanks to "Sjaak" for the solution!!
marked this as an answer
Most relevant based on info available
Most Relevant Answer
For the devs: Consider a new command line option maybe?
marked this as an answer
Most relevant based on info available
Most Relevant Answer
This has to be fixed ASAP. Its a bloody hassle if you are downloading links that open another program... :(
marked this as an answer
Most relevant based on info available
Most Relevant Answer
This is a big problem.
Chrome could solve security risks in different ways.
We want you to always come back to the run option ...
marked this as an answer
Most relevant based on info available
Most Relevant Answer
this update is annoying, and it needs to be reverted.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
I think I'll have to switch browsers because of this, too T-T
marked this as an answer
Most relevant based on info available
Most Relevant Answer
I used Jonathan Rojas' solution above and can confirm that it works in Win7 (should also work in Win10).

https://cloud.google.com/docs/chrome-enterprise/policies/?policy=ExternalProtocolDialogShowAlwaysOpenCheckbox

Once the external app is launched from a URL in Chrome, and the "Always Open" check box is selected, the Chrome Preferences file is auto-edited with the protocol handler entry:

"protocol_handler":{"excluded_schemes":{"XXXXXX":false}}

Subsequent clicks to launch the app work without a prompt.
  1. Update Chrome to v79.
  2. Add the entry below to the Windows Registry. You can just save the text below the dashed line to a new .REG text file, then double-click on it and confirm adding the single entry to the registry.
  3. >> Restart Chrome. <<
  4. Launch your external app from your usual URL click.
  5. Check the box "Always open these types of links in the associated app" and click Open.
  6. Issue (hopefully) resolved.
Note that this registry entry affects HKLM, not HKCU.

---------------------------------------

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Google\Chrome]
"ExternalProtocolDialogShowAlwaysOpenCheckbox"=dword:00000001
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Thank you very much :3 !
marked this as an answer
Most relevant based on info available
Most Relevant Answer
good bye chrome, fuck you!
marked this as an answer
Most relevant based on info available
Most Relevant Answer
This is beyond frustrating. I join many Zoom meetings a day, and having Chrome jack my focus and require a button click every time is infuriating. The workaround of using a registry key is not possible in my environment, because it's a corporate environment where the average user does not have access to the registry (or the policies, for Mac, since we use Macs as our development laptops).

The Chrome team needs to be more cognizant of wasting their users' time. Firefox is looking better every day.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
We need a solution for dummies like me. I am in sales and do many zoom meetings daily.
Arghhhhh
marked this as an answer
Most relevant based on info available
Most Relevant Answer

For Windows:
Open SecureCRT, Putty, Telnet without asking box:
1. Close Chrome
2. Edit C:\Users\<username>\AppData\Local\Google\Chrome\User Data\Default\Preferences
Search key word: safebrowsing, end then add the string before:
"protocol_handler":{"excluded_schemes":{"telnet":false}},"safebrowsing"
3. Save
marked this as an answer
Most relevant based on info available
Most Relevant Answer

For Windows:
Open SecureCRT, Putty, Telnet without asking box:
1. Close Chrome
2. Edit C:\Users\<username>\AppData\Local\Google\Chrome\User Data\Default\Preferences
Search key word: safebrowsing, end then add the string before:
"protocol_handler":{"excluded_schemes":{"telnet":false}},"safebrowsing"
3. Save
marked this as an answer
Most relevant based on info available
Most Relevant Answer
For chrome 79 I got it working with this registry entries to get past the popup:

Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Google\Chrome]
"ExternalProtocolDialogShowAlwaysOpenCheckbox"=dword:00000001

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Google\Chrome\URLWhitelist]
"1"="tel:*"
"2"="telnet:*"

add more whitelist entries if needed.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Pascal- for those of us that aren't coders, is there a way to do make this change- and on a mac?
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Ditto, here.  Super frustrating.  An unnecessary, annoying extra click, at least 10 times per business working day.  In the best case, this was a misguided security "feature", that doesn't really add all that much security and detracts from usability, in which case it should just be backed out.  In the worst case, this is an unfair, monopolistic business practice intended to help Hangouts, and harm competition like Zoom, Skype, and others.  Either way, I'm hopeful that Google will do the right thing and make this configurable again.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Any recommendations for an alternate browser without this issue? (a defect made on purpose is still a defect in my book)
marked this as an answer
Most relevant based on info available
Most Relevant Answer
See Tony Maeller's response above, on 12/30/19, which includes references to others that helped him find the solution.

Go into notepad, copy in his few lines, save the file as "fix.reg" on your desktop, and BE SURE TO change the type of the file to "*.*" (from *.txt - if you don't do that you'll end up with a file named fix.reg.txt)
Save and exit notepad.
Navigate to your desktop and double click on the fix.reg file.

Many thanks to him for making this so easy.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Plz help youtube keeps freezing after 30 seconds or so?
marked this as an answer
Most relevant based on info available
Most Relevant Answer
It's utterly annoying when trying to work from sharepoint. Everytime i click a word file, this prompt pops up. I'm switching browser, i guess.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Actually - it is not so difficult (phew) to modify this (in windows):
* open registry editor (regedit)
* navigate to "Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Policies"
* if there is no key called "Google" - create one
* Under the "Google" key navigate to "Chrome" (again - if does not exist, create one)
* create a new DWORD value key called "ExternalProtocolDialogShowAlwaysOpenCheckbox"
* Set the value to 1

Next time you try to open an external application - the check box will be displayed!
Click on the checkbox, and you would not be asked again!!!!

[This is in fact the same solution as offered above .by Jonathan Rojas and Tony Maeller - but in a more concise form - they deserve the credit - so thank you guys]
marked this as an answer
Most relevant based on info available
Most Relevant Answer
One small addition to Ido's post: need to reboot Chrome for the "fix" to work! Perfect!!!! Thanks, Ido and the previous poster with the same, but a bit more complex, solution.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
I've tried adding all sorts of things to the registry like one of the articles said above, but that didn't work. Apparently uninstalling chrome, reinstalling the old version, ticking the checkbox then updating again works, but I haven't tried that yet - and quite frankly, nobody should have to try any of this. It's ridiculous that such a basic feature should be removed, and it's evidently going to cost them. Anyone who ever had to interact with that dialogue box before will now probably no longer want to use chrome because it's such a pain to click an extra button every time you want to go into a call, or open any app from inside chrome. Might even switch to Chromium Edge at this rate because it's just a reskin and it has the checkbox as far as I know. Anyway, this isn't gonna change anything, and Google are probably gonna do too little too late to fix it.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Had all the same problems, been searching for fix. I'm on Zoom 10-15 times a day. This worked for me on Mac with Chrome version 79.0.3945.130:


For Windows:

1. Apply the "External​Protocol​Dialog​Show​Always​Open​Checkbox" registry policy
2. Or edit the registry and add a REG_DWORD registry entry to:

Software\Policies\Google\Chrome\ExternalProtocolDialogShowAlwaysOpenCheckbox

For macOS:

Open Terminal and enter:

defaults write com.google.Chrome ExternalProtocolDialogShowAlwaysOpenCheckbox -bool true

Quit and restart Chrome to see the checkbox
marked this as an answer
Most relevant based on info available
Most Relevant Answer
We're running a web based software for a company, there this change had a massive impact on daily business.

Edit: With the helpful answer above I've created a registry key - file, which worked well:

Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Google\Chrome\URLWhitelist]
"1"="webclientprintiv://*"

Note: weblicentprintiv is the protocol of the software we use.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
We have just run into this issue - we receive multiple prompts when using Sonicwall Secure Endpoint Manager.  Adding the registry whitelist for "sonicwallsem://*" works for now.  

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Google\Chrome\URLWhitelist]
"1"="sonicwallsem://*"

Any progress on a UI so we can let users choose to remember handlers?
marked this as an answer
Most relevant based on info available
Most Relevant Answer
marked this as an answer
Most relevant based on info available
Most Relevant Answer
So I was annoyed at first at this problem, and the answers were hard to understand for a noobie like me. Eventually, I found the answer with the help of two answers.
Credit: Tony Maeller and Carla Curtis 8838


First, make sure your version is chrome 79 or higher by going to the three dots menu, look for the help section, and about.
Second, go to notepad and copy-paste the text below:

 Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Google\Chrome]
"ExternalProtocolDialogShowAlwaysOpenCheckbox"=dword:00000001


___________________________________________________________________________<-dont copy the line or anything below it including this text.
 
Third, click save as, and name the file fix.reg
Also in the dropdown below it, select all files.


Fourth, find your file where you saved it. Say yes to adding it to the registry.

Fifth, exit chrome and open again. Go to your link and open it.
^
|
Very Important

It will work if you follow all directions carefully and Happy Browsing to you. =)
marked this as an answer
Most relevant based on info available
Most Relevant Answer
thank you.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
You're welcome!
marked this as an answer
Most relevant based on info available
Most Relevant Answer
thank you !! ( confirmed working w/ win10 + chrome79 )
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Is there an equivalent MacOS version of this fix? Where do I put 
ExternalProtocolDialogShowAlwaysOpenCheckbox 

from

?
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Mac instructions (from https://www.jroeder.net/2020/02/04/bring-back-always-open-these-types-of-links-in-the-associated-app-to-google-chrome/):

  1. Quit Google Chrome
  2. Open up Terminal
  3. Copy and paste the following code at the terminal prompt:

    defaults write com.google.Chrome ExternalProtocolDialogShowAlwaysOpenCheckbox -bool true

  4. Restart Google Chrome
marked this as an answer
Most relevant based on info available
Most Relevant Answer
@James Roeder, your fix doesn't work. I only get a syntax error.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
The solution described in the post by @sd4544 by defining a policy ExternalProtocolDialogShowAlwaysOpenCheckbox worked for me (Windows 10).
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Well here is the windows solution:
So I was annoyed at first at this problem, and the answers were hard to understand for a noobie like me. Eventually, I found the answer with the help of two answers.
Credit: Tony Maeller and Carla Curtis 8838


First, make sure your version is chrome 79 or higher by going to the three dots menu, look for the help section, and about.
Second, go to notepad and copy-paste the text below:

 Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Google\Chrome]
"ExternalProtocolDialogShowAlwaysOpenCheckbox"=dword:00000001


___________________________________________________________________________<-dont copy the line or anything below it including this text.
 
Third, click save as, and name the file fix.reg
Also in the dropdown below it, select all files.


Fourth, find your file where you saved it. Say yes to adding it to the registry.

Fifth, exit chrome and open again. Go to your link and open it.
^
|
Very Important

It will work if you follow all directions carefully and Happy Browsing to you. =)
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Thanks!  That worked like a charm for Chrome  80.0.3987.87
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Regedit Worked for me on Windows10 on Chrome 79. THANKS!
Note: I did not have Keys for Google or Chrome under \HKEY_LOCAL_MACHINE\Software\Policies so had to create them. The NEW DWord with Value Name: ExternalProtocolDialogShowAlwaysOpenCheckbox and Value Data: 41000000 (Hex).
marked this as an answer
Most relevant based on info available
Most Relevant Answer
If you don't know how to get it done. I've created a simple application to make it work seamlessly for both mac and pc. www.sendwhatsappmsg.com/open-whatsapp-desktop
marked this as an answer
Most relevant based on info available
Most Relevant Answer
This registry fix brought back the checkbox for me and solved the problem:
https://cloud.google.com/docs/chrome-enterprise/policies/?policy=ExternalProtocolDialogShowAlwaysOpenCheckbox
marked this as an answer
Most relevant based on info available
Most Relevant Answer
For linux users
Create folder
mkdir -p /etc/opt/chrome/policies/managed/
Create an empty Json file
touch /etc/opt/chrome/policies/managed/managed_policies.json
In this Json file, put the following content:
{
"ExternalProtocolDialogShowAlwaysOpenCheckbox": true
}
That’s it! Start Chrome the checkbox should be there.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
@Garry Smith 1545 Great! it's worked
marked this as an answer
Most relevant based on info available
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.