/chrome/community?hl=en
This content is likely not relevant anymore. Try searching or browse recent questions.
Flash player not working after enabled - Chrome 76, Fedora 30 0 Recommended Answers 11 Replies 289 Upvotes
1 Recommended Answer
$0 Recommended Answers
1 Relevant Answer
$0 Relevant Answers
I've just installed the newest stable release of Chrome.  I'm trying to use a site that uses Flash (100% not my choice/control, and I have no option in the matter at this time).  I've enabled it, told it to allow Flash for that site, etc...gone through all the troubleshooting steps.  But every time I try to go to something that uses Flash I get the little puzzle piece icon and it says "Download failed".  I've reinstalled, I've confirmed everything is up to date, etc...  I've gone to the main Flash site to test as well, and a couple of others, to confirm it's nothing site specific.  Any other things I can do/check?
Relevant Answer Relevant Answers (0)
All Replies (11)
Relevant Answer
A few more details as I poke more.  If I go to chrome://components , it says:
Adobe Flash Player - Version: 0.0.0.0
Status - Up-to-date

I click the update button there - it briefly goes to Component Not Updated, then back to Up-To-Date.

If I go to the command line and type "dnf list installed | grep flash", I get "flash-plugin.x86_64                               32.0.0.238-release                  @adobe-linux-x86_64"

If I go to chrome://version, it shows:
"Flash 24.0.0.189 internal-not-yet-present"

And the ~/.config/google-chrome/PepperFlash directory is empty.

But if I go to the Flash site and try to install the PPAPI I get a very long error message that it failed to process the component flash-player-ppapi, ending in "failed to parse part: cannot parse text or number 'null'".  I was able to install flash-player-ppapi from the command line, but still no change in behaviour.

So very much looks like the (theoretically) built-in version of PepperFlash is not installed, despite the fact I thought it was supposed to come with.  And getting the NPAPI version isn't helping in the slightest.  I tried checking for an available package with pepper or Pepper in it, but no matches.  :-(
marked this as an answer
Relevant Answer
Same issue exactly on latest version of Chrome on Arch Linux, but no problem in Chromium and also no problem in Windows 7.
marked this as an answer
Relevant Answer
im having the same issues as well, just started
marked this as an answer
Relevant Answer
Same issue on Chrome Version 77.0.3865.90 (Official Build) (64-bit) from the AUR on Manjaro Linux.

Perhaps an issue with the AUR build?
marked this as an answer
Relevant Answer
I'm also experiencing this very frustrating issue.

Running Chrome 77.0.3865.120 (Official Build) (64-bit) on Fedora 30, x64 which Flash Plugin 32 from Adobe.
marked this as an answer
Relevant Answer
I can confirm, it is working on a fresh install of Debian 10.1, but alas, it is not working on my fresh install of Arch Linux :(
marked this as an answer
Relevant Answer
Same on Fedora 31 with google-chrome-stable-78.0.3904.87-1.x86_64
marked this as an answer
Relevant Answer
Same issue on Lubuntu 19.10 (Chrome stable freshly installed and Chrome Dev - stopped updating on 32.0.0.270).
marked this as an answer
Relevant Answer
Same issue on Fedora 31 google-chrome-stable-78.0.3904.108-1.x86_64
marked this as an answer
Relevant Answer
I had the same issue when running Chrome 79 on Ubuntu 19.1.

I was able to get Flash Player working by doing the following:
  1. Download the latest version of flash player from https://get.adobe.com/flashplayer/ .  You'll want to get the tar.tz file.
  2. Unzip the tar.tz's contents into /usr/lib/adobe-flashplugin/
  3. Edit the /usr/share/applications/google-chrome.desktop file.
    1. Locate the line that starts with "Exec=" and insert the following text: "--ppapi-flash-path="/usr/lib/adobe-flashplugin/libpepflashplayer.so" --ppapi-flash-version=version_number".  The version_number should match that of the flash player you just downloaded.  
    2. For example, the line should now look something like this:   Exec=/usr/bin/google-chrome-stable --ppapi-flash-path="/usr/lib/adobe-flashplugin/libpepflashplayer.so" --ppapi-flash-version=32.0.0.303  %U
  4. Enjoy using Flash Player!
marked this as an answer
Relevant Answer
I was able to get Flash Player to work on an Intel NUC7 with the LibreELEC OS and the Chrome addon.
  • From any PC, download flash_player_ppapi_linux.x86_64.tar.gz from https://get.adobe.com/flashplayer/otherversions/.
    • Select OS: "Linux (64 bit)"
    • Select version: "FP 32 for Linux 64-bit (tar.gz)- PPAPI"
  • Transfer flash_player_ppapi_linux.x86_64.tar.gz to /storage/Downloads.
  • SSH into the LibreELEC box.
  • cd /storage/.ko??/addons/browser.chrome/bin
  • Make directory named PepperFlash.
  • Extract flash_player_ppapi_linux.x86_64.tar.gz to PepperFlash subdirectory.
  • Edit the chrome-start script and
  • Add the ppapi options to the 'start chrome' block (use the correct version for your download)
​--ppapi-flash-path="YOURPATH/PepperFlash/libpepflashplayer.so" \
--ppapi-flash-version="32.0.0.303" \
marked this as an answer
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
Delete post?
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
Report post
What type of post are you reporting?
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
/chrome/threads
//accounts.google.com/ServiceLogin
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Deleted
Unable to delete reply.
Removed from Answers
Marked as Recommended Answer
Removed recommendation
Undo
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Locked
Unlocked
Unable to lock
Unable to unlock
Pinned
Unpinned
Unable to pin
Unable to unpin
Marked
Unmarked
Unable to mark
Reported as off topic
/chrome/profile/0