/chrome/community?hl=en
This content is likely not relevant anymore. Try searching or browse recent questions.
-
8/1/19
Chrome 76 64-bit high CPU usage on tabs with Javascript-intensive functions 0 Recommended Answers 59 Replies 227 Upvotes
1 Recommended Answer
$0 Recommended Answers
Last edited 8/15/19
On my work laptop, my Chrome updated to the latest stable release 76 (76.0.3809.87) today and now Chrome is virtually unusable for the majority of the tools I use for my job.

Specifically, taking actions that invoke Javascript- or call-intensive functions causes the browser tab in question to shoot to 100% CPU in the Chrome task manager and the web page typically appears to freeze until whatever is causing it to freeze resolves itself. The following are examples of actions that cause the behavior:
  • clicking filter elements on a PowerBI report
  • typing in the reddit.com search bar (CPU spike immediately ends once the suggestions for what has been typed so far have loaded)
  • taking virtually any action in Azure DevOps Boards or Backlogs

I was using Chrome yesterday fine up until I left. I always hibernate my work laptop prior to leaving for the day and was not on it last night. In fact, it is likely that the device went to sleep and woke up on the same network as a result of this behavior. There really is no potential for malware involved, but I ran every available scan anyways to no avail.

I've searched long and hard today on how to remedy this issue but cannot seem to find anyone that has experienced this specific situation. I can only conclude that there is some new or changed behavior in Chrome 76 that did not exist in the version 75 I had yesterday.

Please, help me track this down. I'd rather not have to swap all of my work functions to another browser.
All Replies (59)
8/1/19
I've got the same issue, together with many people.

Everything was working fine until version 76.0.3809.87, now CPU goes up to 100%.
A lot of WebApps, including Google Calendar and Gmail, are almost frozen.

My system should be secure enough to exclude the malware cause, I also tried to disable all my extensions and to work in Incognito mode to avoid any external interference, but the issue was still there.
Only Chrome v76 is affected, older versions or other browsers work fine, so I also exclude network issues.

Hope this post can help to investigate
Last edited 8/1/19
marked this as an answer
Helpful?
8/1/19
Your own https://console.developers.google.com  website is running particularly poor because of these changes, I was editing Keys in the console this morning on Version 75 and updated to 76, The same page loads are talking multiples of 5 to load up and perform the same actions.


Cmon guys! whats going on
marked this as an answer
Helpful?
-
8/1/19
Good point on the extensions bit mentioned above. I too attempted to disable every Chrome extension I had to see whether any were causing the issue, but it still persisted. Chrome's own task manager verified this too once I re-enabled them all since they saw hardly any CPU time or usage during any of my tests.
marked this as an answer
Helpful?
-
8/2/19
A few other members of my work team have accidentally taken the Chrome 76 update and now are also experiencing terrible performance in most web applications that are call-heavy. Please address this glaring problem.
marked this as an answer
Helpful?
-
8/5/19
Even Google Maps performs terribly in this version of Chrome. It is very frustrating that this clearly was not tested or not reported in testing.
marked this as an answer
Helpful?
-
8/8/19
It's been over a week with no response to this. It is still a glaring issue and needs addressed, even if just to say "we're aware of the issue and researching a fix".
marked this as an answer
Helpful?
8/8/19
We decided to downgrade to 75.x until this issue is fixed. Hope this will not take long to be taken in charge, otherwise, we'll directly change the browser to use.
marked this as an answer
Helpful?
8/8/19
Also having issues since updating to the latest version (76.0.3809.100). Our finance team uses Acumatica and content just spins and never loads properly now. Confirmed it only happens when we upgrade to this version. Having my staff use Microsoft Edge in the meantime... yuck.
marked this as an answer
Helpful?
8/9/19
Happens too on macOS.
marked this as an answer
Helpful?
This reply is no longer available.
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
Delete post?
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
/chrome/threads
//accounts.google.com/ServiceLogin
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Deleted
Unable to delete reply.
Removed from Answers
Marked as Recommended Answer
Removed recommendation
Undo
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Locked
Unlocked
Unable to lock
Unable to unlock
Pinned
Unpinned
Unable to pin
Unable to unpin
Marked
Unmarked
Unable to mark
Reported as off topic
/chrome/profile/0?hl=en