/chrome/community?hl=en
/chrome/community?hl=en
7/21/09
Original Poster
starfish.warrior

I can't kill a chrome process that has become unresponsive

I can open a new chrome process but the old one just sits there, mocking me. I even tried
 
taskkill /F /FI "IMAGENAME eq chrome*"
 
but nothing.
Community content may not be verified or up-to-date. Learn more.
Recommended Answers (2)
Were these answers helpful?
How can we improve them?
All Replies (58)
dwight.stegall
7/22/09
dwight.stegall
Chrome is the only browser with it's own built-in version of Windows Task Manager that kills unresponsive apps.

To Open it click on the Page Icon (top-right) > Developer > Task Manager.

You should click on everything in chrome with the left mouse button. middle mouse wheel and right mouse button. Also go back and do them with the shift key pressed. You will be amazed at all of the hidden stuff you will find. Do this with every application on your computer and you will learn more in a day that most people do in a lifetime. :))


js1473
8/6/09
js1473
I experience the same problem also.
 
I cannot seem to kill the underlying frozen Google Chrome manager process that performs all of the background interprocess communication and things like the Downloads, History, and Speeddial tabs.
 
I also believe that Adobe Flash not being properly supported for x64 systems is the main trigger for crashing Google Chrome's manager process which leads to this condition.
 
The only solution that I have found is to restart my entire computer which is very lame.
 
Mind you, Google Chrome still works, but with reduced functionality. The Speeddial, History, and Downloads are not functioning and the cookies are cleared or inaccessible when this condition occurs. Also, the memory function of which tabs are open is lost and not accessible.
 
Any ideas on how to kill the rogue process so that I can restart Chrome without having to restart my entire computer? This would obviously be a temporary solution to the underlying problem causing the initial crash, but it would make my life easier and allow me to continue with Chrome as a very happy user.
 
As it is, I'm so happy with Chrome that even with this huge annoying problem, I still do not mind too much to restart my computer or even to just continue using Chrome in the defunct mode because it loads websites with such great speed thanks to making each tab a separate process and thereby distributing the CPU loads on my cores coupled with the amazing speed at which it loads and creates a new tab. There is no browser even close to the speed of Chrome and this is the sole reason I use it. Forget about Firerfox, IE, Opera, and Safari. None of them allow me to click 100 webpages and allow them to load in the background without any sort of a pause or delay.
Kleskowy
8/27/09
Kleskowy
I experience the same problem. I'm operating on Windows Vista Business SP1 64-bit, tried it with latest Chrome stable release (2.0.172.37) and with the latest beta release (4.0.202.0) - same problem occurs.
 
What is more, Chrome seems to lock up TCP/IP stack - I can close Chrome window, but there still is a chrome.exe process in my TaskManager. I can't kill it even with TASKKILL /F /T /IM chrome*
 
When chrome freezes, and I close it's window, also other browser (Firefox 3.5) doesn't seem to be loading pages, which really annoys me.
 
Flash is the main trigger for Chrome lock-up, I believe, or maybe the 64-bit OS.
 
I'd be grateful if new releases of Chrome would fix that problem.
9/3/09
Expert - Google Employee
Google Chrome Guide
Thanks for reporting this problem, everyone, and thanks for the tips, dwight.

Could you let me know the answers to the questions below? It may help us get some leads as to what's going on.

- When does this problem occur? Does it only happen when you visit certain sites? If so, which sites?
- Kleskowy, you mentioned that this may be related to Flash. Which version of Flash are you using? You can find out by entering "about:plugins" into the Google Chrome address bar, and scrolling down to the section for Flash.
- Finally, do you have any security software installed? If so, which ones?

Thanks for your help.

Cheers,
Kal
js1473
9/10/09
js1473
Mostly Flash heavy sites like Facebook, YouTube, etc.
 
I also think that it is related to Flash, possibly the lack of a 64-bit version of Flash. I am also using an x64 Vista. I also noticed this same problem with the Windows Seven RC1 x64 edition. I'm using version 10.0 I think. I would try to "about:plugins", but the main Chrome process has crashed already and I do not have time to restart my computer just to kill that process so that I can bring Chrome back to normal. All of those main functions of the main Chrome process are inaccessible such as the Opera-styled dial pad page, history, downloads, and about:plugins....etc....
 
I have McAfee VirusScan 8.7.0i, ClamWin 0.95.2 ( http://www.clamwin.com/ ), and just Windows Defender and Windows Firewall. I have Zone Alarm installed, but disabled because it requires me to purchase it now even though they advertise the free version on their website which the download does not work for some reason.
 
I personally believe that Flash is the culprit. I notice the memory go waaaaaay up for the Flash tab process and the CPU of the Flash tab process also spikes after an incident occurs. Under normal operation, I notice no problems until suddenly Flash gets stuck hanging on some sort of calculation maybe.
 
As far as I understand, the Flash plugin and so on have not been rewritten or released for the x64 architecture. Currently they are using the x32 version running under a virtual mode of some type. ( http://blogs.zdnet.com/Bott/?p=509 ) I still do not think that they have corrected the problem.
 
Of course I would like Chrome and Flash to behave properly, but at the least, I would like to be able to purposely crash/kill the main Chrome process after an incident so that I can restore Chrome to normal operation without having to restart my entire machine. I've tried many things from DiamondCS's Advanced Process Termination software to other esoteric ways to kill processes. I've tried killing process trees with System Internal's Process Explorer running in Administrator mode and to no avail, nothing seems to work except restarting the machine.
52 MORE
JaredFernandez
11/6/12
JaredFernandez
I'm so glad it helped!
 
On my device, I have a three-part corporate-installed McAfee HIPS program that must stay installed. I found that by disabling just the McAfee firewall portion of the Host Intrusion Prevention program, this problem never occurred again!
 
McAfee really needs to figure out the problem with their network filter drivers...
 
This question is locked and replying has been disabled. Still have questions? Ask the Help Community.

Badges

Some community members might have badges that indicate their identity or level of participation in a community.

 
Expert - Google Employee — Googler guides and community managers
 
Expert - Community Specialist — Google partners who share their expertise
 
Expert - Gold — Trusted members who are knowledgeable and active contributors
 
Expert - Platinum — Seasoned members who contribute beyond providing help through mentoring, creating content, and more
 
Expert - Alumni — Past members who are no longer active, but were previously recognized for their helpfulness
 
Expert - Silver — New members who are developing their product knowledge
Community content may not be verified or up-to-date. Learn more.

Levels

Member levels indicate a user's level of participation in a forum. The greater the participation, the higher the level. Everyone starts at level 1 and can rise to level 10. These activities can increase your level in a forum:

  • Post an answer.
  • Having your answer selected as the best answer.
  • Having your post rated as helpful.
  • Vote up a post.
  • Correctly mark a topic or post as abuse.

Having a post marked and removed as abuse will slow a user's advance in levels.

View profile in forum?

To view this member's profile, you need to leave the current Help page.

Report abuse in forum?

This comment originated in the Google Product Forum. To report abuse, you need to leave the current Help page.

Reply in forum?

This comment originated in the Google Product Forum. To reply, you need to leave the current Help page.