/chrome/community?hl=en
/chrome/community?hl=en
7/12/14
Original Poster
Google user

Chrome doesn't start (window doesn't appear) on Fedora 20 Linux


(To the moderator: please do NOT mark this as a duplicate of https://groups.google.com/a/googleproductforums.com/d/topic/chrome/tdlOv4V4jDk like you did last time.
That discussion is mainly for Windows 8 - it's really difficult for users to go through the 100+ unrelated posts there to find a solution (and there is none anyway). I'm reposting this since all my posts there didn't succeed in restoring my original post. I still don't see why all 'chrome not starting' issues related to different OSs should be muddled into one topic).

I have google chrome version 35.0.1916.153 on a Fedora 20 x86_64 machine (upgraded from Fedora 18). google-chrome no longer starts - its window doesn't appear. I upgraded to this version of Chrome from an older version to find that the problem persists.  Running google-chrome just gives

$ google-chrome
 PID namespaces supported Network namespace supportedbut failed: errno = Operation not permitted
<hang> <no window appears and this doesn't return>

The list of processes shows

$ ps -ef | grep chrome
user     26747 14220  1 20:22 pts/4    00:00:00 /opt/google/chrome/chrome
user     26752 26747  0 20:22 pts/4    00:00:00 /opt/google/chrome/chrome --type=sandbox-ipc
user     26753 26747  0 20:22 pts/4    00:00:00 [chrome-sandbox] <defunct>
user     26755 26641  0 20:22 pts/6    00:00:00 grep --color=auto chrome

I tried creating a new user account and running chrome - that doesn't work either. I'm able to run it as root though! - but that's obviously not what anyone wants.
Community content may not be verified or up-to-date. Learn more.
All Replies (4)
7/19/14
Original Poster
Google user

A stack trace shows that google-chrome is stuck as shown below (full log is attached).

[....]
readlink("/proc/self/exe", "/opt/google/chrome/chrome", 4096) = 25
prctl(PR_SET_NAME, 0x7fb3426f1f58, 0x7fb3426f1f40, 0x656d6f72, 0x7fb3426f1f58) = 0
uname({sys="Linux", node="localhost.localdomain", ...}) = 0
stat("/", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
stat("/home", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
stat("/home/uday", {st_mode=S_IFDIR|0711, st_size=4096, ...}) = 0
stat("/home/uday/.pki", {st_mode=S_IFDIR|0700, st_size=4096, ...}) = 0
stat("/home/uday/.pki/nssdb", {st_mode=S_IFDIR|0700, st_size=4096, ...}) = 0
statfs("/home/uday/.pki/nssdb", {f_type="EXT2_SUPER_MAGIC", f_bsize=4096, f_blocks=149141298, f_bfree=59193523, f_bavail=51611827, f_files=37888000, f_ffree=36994892, f_fsid={911483965, 744237665}, f_namelen=255, f_frsize=4096}) = 0
readlink("/proc/self/exe", "/opt/google/chrome/chrome", 4096) = 25
open("/opt/google/chrome/icudtl.dat", O_RDONLY) = 3
fstat(3, {st_mode=S_IFREG|0644, st_size=9980368, ...}) = 0
mmap(NULL, 9980368, PROT_READ, MAP_SHARED, 3, 0) = 0x7fb32baf6000
access("/home/uday/.config/google-chrome", F_OK) = 0
open("/home/uday/.config/google-chrome/Consent To Send Stats", O_RDONLY) = -1 ENOENT (No such file or directory)
access("/proc/16303/oom_score_adj", F_OK) = 0
creat("/proc/16303/oom_score_adj", 0666) = 4
write(4, "0", 1)                        = 1
close(4)                                = 0
gettid()                                = 16303
gettid()                                = 16303
access("/opt/google/chrome/chrome-sandbox", F_OK) = 0
socketpair(PF_LOCAL, SOCK_SEQPACKET, 0, [4, 5]) = 0
pipe([6, 7])                            = 0
clone(child_stack=0, flags=CLONE_CHILD_CLEARTID|CLONE_CHILD_SETTID|SIGCHLD, child_tidptr=0x7fb34285bd10) = 16308
socketpair(PF_LOCAL, SOCK_SEQPACKET, 0, [8, 9]) = 0
stat("/opt/google/chrome/chrome-sandbox", {st_mode=S_IFREG|S_ISUID|0755, st_size=18600, ...}) = 0
access("/opt/google/chrome/chrome-sandbox", X_OK) = 0
socket(PF_LOCAL, SOCK_DGRAM, 0)         = 10
rt_sigprocmask(SIG_SETMASK, ~[RTMIN RT_1], [], 8) = 0
clone(child_stack=0, flags=CLONE_CHILD_CLEARTID|CLONE_CHILD_SETTID|SIGCHLD, child_tidptr=0x7fb34285bd10) = 16309
rt_sigprocmask(SIG_SETMASK, [], ~[KILL STOP RTMIN RT_1], 8) = 0
recvmsg(8,  PID namespaces supported Network namespace supportedbut failed: errno = Operation not permitted
0x7fff0955aed0, 0)           = ? ERESTARTSYS (To be restarted if SA_RESTART is set)
--- SIGCHLD {si_signo=SIGCHLD, si_code=CLD_EXITED, si_pid=16309, si_status=1, si_utime=0, si_stime=0} ---
recvmsg(8,

Ultimately, chrome-sandbox becomes defunct. Without any error or warning message being output, I can't see why this is not a bug in chrome.
7/19/14
Original Poster
Google user

This post (https://code.google.com/p/chromium/issues/detail?id=110756) appears to be related but there's nothing there to solve this. In addition, I have another Fedora 20 system where google-chrome works with the same kernel version. So this doesn't appear to be a kernel related issue alone.
7/19/14
Original Poster
Google user
With an update to chrome version 36.0.1985.125, the error message has been improved and made more accurate, but still the same problem.

$ google-chrome
The setuid sandbox is not running as root. Common causes:
  * An unprivileged process using ptrace on it, like a debugger.
  * A parent process set prctl(PR_SET_NO_NEW_PRIVS, ...)
Failed to move to new namespace: PID namespaces supported, Network namespace supported, but failed: errno = Operation not permitted

I have kernel version 3.14.4-200.fc20.x86_64
7/19/14
Original Poster
Google user

I found the problem. The posts at

https://code.google.com/p/chromium/issues/detail?id=31077
https://github.com/travis-ci/travis-ci/issues/938

have the solution. The partition where chrome is installed shouldn't be mounted with nosuid flag. Getting rid of nosuid from the entry for /opt in /etc/fstab solves the problem.

From some of the comments there,

-------------------------------------------
#10 ev...@chromium.org
We hope to eliminate our SUID-based sandboxing in the near future.
But for now, we require the SUID helper for sandboxing.
---------------------------------------------

I wish the error message could be further improved by adding the following as a common cause.

* The file system on which chrome is installed is mounted with the  nosuid option

Were these replies helpful?
How can we improve them?
 
This question is locked and replying has been disabled. Still have questions? Ask the Help Community.

Badges

Some community members might have badges that indicate their identity or level of participation in a community.

 
Expert - Google Employee — Googler guides and community managers
 
Expert - Community Specialist — Google partners who share their expertise
 
Expert - Gold — Trusted members who are knowledgeable and active contributors
 
Expert - Platinum — Seasoned members who contribute beyond providing help through mentoring, creating content, and more
 
Expert - Alumni — Past members who are no longer active, but were previously recognized for their helpfulness
 
Expert - Silver — New members who are developing their product knowledge
Community content may not be verified or up-to-date. Learn more.

Levels

Member levels indicate a user's level of participation in a forum. The greater the participation, the higher the level. Everyone starts at level 1 and can rise to level 10. These activities can increase your level in a forum:

  • Post an answer.
  • Having your answer selected as the best answer.
  • Having your post rated as helpful.
  • Vote up a post.
  • Correctly mark a topic or post as abuse.

Having a post marked and removed as abuse will slow a user's advance in levels.

View profile in forum?

To view this member's profile, you need to leave the current Help page.

Report abuse in forum?

This comment originated in the Google Product Forum. To report abuse, you need to leave the current Help page.

Reply in forum?

This comment originated in the Google Product Forum. To reply, you need to leave the current Help page.