/chrome/community?hl=en
/chrome/community?hl=en
1/4/11
Original Poster
jamvng

Mailto links are not working in Chrome

Google Chrome version:10.0.612.3 (Official Build 69636) dev
Operating System: Windows 7
Error Message:Extensions installed:
Please describe your question/comment in detail (for example, steps to reproduce the problem):
 
When I click on mailto links in Chrome, it does not do anything. My default mail client is Windows Live Mail. In Firefox and Internet Explorer, mailto links would open a Windows Live Mail compose window properly, just not in Chrome. I've previously had an extension that made mailto links open in a Gmail window, but I've uninstalled that so that I can use an offline email client again (Windows Live Mail). And now mailto links just don't work in Chrome anymore.
 
I've tried reinstalling Chrome, used the normal version (non dev), used the Canary version, deleted my user data from the AppData folder, tried it in another user account on my computer; and nothing works.
Community content may not be verified or up-to-date. Learn more.
Recommended Answers (2)
Were these answers helpful?
How can we improve them?
All Replies (41)
daniel64
1/4/11
daniel64
A possible solution might be to reset the mail client by going to Control Panel --> Default Programs --> Set your program defaults, clicking Windows Live Mail, or some other mail program, and confirm that it is set as the default mail program. If Windows Live Mail doesn't work, then it might be useful to check if others do, to find out if it is Windows Live Mail that is causing the problem.
1/4/11
Original Poster
jamvng
I've tried to narrow down the problem, but it's hard. All other mailto links work (on other browsers, other programs, etc); it's just Chrome. At the same time, I've tried wiping out Chrome (from AppData), and clean installing it, and it still doesn't work. I've tried making a new user profile on WIndows, and installing Chrome and doing the same thing; mailto links in Chrome still do not work.
 
From the above troubleshooting, seems like it's neither WIndows Live Mail, Chrome, or Windows' fault. haha
@daniel64 Yes I've tried that too.
pixelman
1/10/11
pixelman
jamvng, my wife's computer is experiencing the exact same issue.  If you find a fix, please post!  She's using Windows 7 Professional 64-bit, btw.
rplst8
2/26/11
rplst8
I'm having the same problem. Mailto links work from IE (Thunderbird loads fine) but not from Chrome.
patjee
2/27/11
patjee
do you guys use adblock plus? i just turned it off, and the mailto links work!
35 MORE
James H Dalton
12/6/13
James H Dalton
Thanks...don't know why I didn't see that, and sure wasted time on a lot of other fixes first!
 
This question is locked and replying has been disabled. Still have questions? Ask the Help Community.

Badges

Some community members might have badges that indicate their identity or level of participation in a community.

 
Expert - Google Employee — Googler guides and community managers
 
Expert - Community Specialist — Google partners who share their expertise
 
Expert - Gold — Trusted members who are knowledgeable and active contributors
 
Expert - Platinum — Seasoned members who contribute beyond providing help through mentoring, creating content, and more
 
Expert - Alumni — Past members who are no longer active, but were previously recognized for their helpfulness
 
Expert - Silver — New members who are developing their product knowledge
Community content may not be verified or up-to-date. Learn more.

Levels

Member levels indicate a user's level of participation in a forum. The greater the participation, the higher the level. Everyone starts at level 1 and can rise to level 10. These activities can increase your level in a forum:

  • Post an answer.
  • Having your answer selected as the best answer.
  • Having your post rated as helpful.
  • Vote up a post.
  • Correctly mark a topic or post as abuse.

Having a post marked and removed as abuse will slow a user's advance in levels.

View profile in forum?

To view this member's profile, you need to leave the current Help page.

Report abuse in forum?

This comment originated in the Google Product Forum. To report abuse, you need to leave the current Help page.

Reply in forum?

This comment originated in the Google Product Forum. To reply, you need to leave the current Help page.