차단된 플러그인

오래되었거나 널리 사용되지 않는 플러그인은 보안 위험이 있을 수 있으므로 Chrome에서 이러한 플러그인을 차단합니다. 플러그인은 브라우저가 Flash 또는 Windows Media 파일과 같은 특정 유형의 웹 콘텐츠를 처리할 수 있도록 돕습니다. Flash와 같은 몇 가지 플러그인은 대부분의 웹사이트에서 사용되며 다른 플러그인은 일부 사이트에서만 사용됩니다.

Chrome이 차단하는 플러그인의 예:

  • 자바
  • RealPlayer
  • QuickTime
  • Shockwave
  • Windows Media Player
  • Adobe Reader X 이전의 Adobe Reader
  • Unity
  • Google 업데이트
  • VLC

차단된 플러그인 실행

일부 플러그인은 Chrome에서 차단하더라도 실행할 수 있습니다. 이 경우 Chrome에서 플러그인을 실행할 권한을 요청하는 메시지가 나타납니다. 이때 신뢰할 수 있는 사이트의 플러그인만 실행해야 합니다.

사이트에서 플러그인을 실행하려면 다음 단계를 따르세요.

  • 플러그인을 이번 한 번만 실행하려면 이번만 실행을 클릭합니다. 플러그인이 실행되며 나중에 사이트를 방문했을 때 플러그인을 실행할 권한을 요청하는 메시지가 다시 표시됩니다.
  • 현재 사이트에서 플러그인을 항상 실행하도록 허용하려면 이 사이트에서 항상 실행을 클릭합니다. 이후에 사이트를 방문할 때 다시 묻지 않고 플러그인을 실행합니다.
  • 이러한 유형의 플러그인 실행을 항상 허용하려면 chrome://plugins로 이동한 다음 플러그인을 찾아서 항상 허용 옆의 확인란을 선택합니다.

플러그인 관리에 대해 자세히 알아보기

널리 사용되지 않는 플러그인을 실행하기 전에 Chrome에서 권한을 요청하는 메시지를 표시하지 않도록 하려면 --always-authorize-plugins 명령줄 플래그를 사용합니다. 명령줄 플래그를 추가하는 방법에 대한 안내는 Chromium 사이트를 참조하세요.

NPAPI 플러그인 지원 중단

2014년 1월부터 Chrome의 NPAPI 플러그인 지원이 중단됩니다. 웹이 계속해서 진화함에 따라 NPAPI 보다 안전성과 성능면에서 뛰어난 기술이 개발되었기 때문에 이러한 결정을 내리게 되었습니다. 따라서 NPAPI 플러그인 역시 위의 차단된 플러그인으로 권한을 요청하는 메시지가 표시되게 됩니다. NPAPI를 사용하는 웹사이트를 발견하시면 웹마스터에게 블로그 포스트(영문) 혹은 이 도움말을 안내해주세요. 최신 브라우저 기술로 이전하고 보다 나은 웹을 만들 수 있도록 도와주셔서 감사합니다.