Out-of-date plug-ins

Plug-ins help browsers process special types of web content, like Flash or Windows Media files. Unlike Google Chrome, plug-ins aren't updated automatically, so over time, your plug-ins may get outdated as new versions are released. Keeping your plug-ins up to date is important, since many exploits on the web target outdated plug-ins with security flaws.

To make sure that you're protected, whenever Google Chrome detects that a common plug-in on a page is out of date with a security vulnerability, a message will appear beneath the address bar notifying you that the plug-in has been blocked.

  • To upgrade to the latest version for that plug-in, click Update plug-in in the message. The download of the plug-in will automatically start or you’ll be taken to that plug-in’s website where you can download its latest version.
  • If you want to run the plug-in without upgrading for the present, click Run this time. The plug-in will be allowed to run and the message will disappear. This is not recommended.

Learn more about managing plug-ins

Note: Although not recommended, if you don't want Google Chrome to notify you when a plug-in is out of date, use the command line flag --allow-outdated-plugins. Instructions on how to add a command line flag can be found on our Chromium site (English only).