Notification

Planning your return to office strategy? See how ChromeOS can help.

Chrome browser system requirements

Your computer should meet the minimum system requirements before you install and use Chrome browser.

It's possible that Chrome might install on other platforms or versions not listed here. However, Google enterprise level support is limited to systems that meet the minimum requirements. Google does not provide support if you install Chrome on any system that does not meet the specified criteria.

Windows

To use Chrome browser on Windows, you'll need:

  • Windows 10 or later or Windows Server 2016 or later
  • An Intel Pentium 4 processor or later that's SSE3 capable

Support timelines

OS version Chrome deprecation release and date Microsoft deprecation date

Windows 7

Chrome 109 is the last version to support this operating system.

Chrome 109 was released January 10, 2023.

January 2020
Windows 8/8.1

Chrome 109 is the last version to support this operating system.

Chrome 109 was released January 10, 2023.

Windows 8: January
2023

Windows 8.1: January 2023

Windows Server 2012

Windows Server 2012 R2

Chrome 109 is the last version to support these operating systems. To ease customer transitions, critical severity security fixes and fixes for bugs where Google is aware of existing exploits will be issued, when feasible, to Chrome 109 on these operating systems until October 10, 2023.

For details, see Sunsetting support for Windows 7/8/8.1 and Windows Server 2012 and Windows Server 2012 R2 in 2023.

October 2023
Windows 10 Not yet scheduled October 2025
Windows 11 Not yet scheduled Not yet scheduled
Windows Server 2016 Not yet scheduled January 2027
Windows Server 2019 Not yet scheduled January 2029
Windows Server 2022 Not yet scheduled Not yet scheduled

Mac

To use Chrome browser on Mac, you'll need:

  • macOS Catalina 10.15 or later

Linux

To use Chrome browser on Linux, you'll need:

  • 64-bit Ubuntu 18.04+, Debian 10+, openSUSE 15.5+, or Fedora Linux 38+
  • An Intel Pentium 4 processor or later that's SSE3 capable

Android

To use Chrome browser on Android, you'll need:

  • Android 8.0 Oreo

Google and related marks and logos are trademarks of Google LLC. All other company and product names are trademarks of the companies with which they are associated.

Was this helpful?

How can we improve it?
Search
Clear search
Close search
Google apps
Main menu
9581353316515826915