This content is likely not relevant anymore. Try searching or browse recent questions.
"Oops, we couldn't import this file. Try again in a few minutes." on trying to import .ics file. 0 Recommended Answers 52 Replies 226 Upvotes
1 Recommended Answer
$0 Recommended Answers
Switched temporarily to FireFox in order to import .ics into Google Calendar. Other reports on this problem have been locked with no solution for Calendar and Chrome. Where are you, Google???
All Replies (52)
I have the same basic problem - can't import an ical calendar file that I exported from Gsuite calendar (so I assume format is fine).  

But unlike other people, it doesn't work for me even if I use MS Edge or Firefox.  

Does anyone know how I might be able to fix this?  When I converted from outlook Gsuite made a calendar separate from my main gsuite account.  Can't just delete that one and rename the one that has all my data...
marked this as an answer
Same problem. I have to use Internet Explorer to import my American Airlines flight ics appointment files into Google Calendar.
marked this as an answer
switched to edge and it worked.  not chrome??
marked this as an answer
Same here. Didn't work in Chrome but worked in Edge. First time I've used Edge. Thanks for the tip!
marked this as an answer
Same here. Worked with edge
marked this as an answer
I have the same problem all the time and use Firefox.
marked this as an answer
Same problem here.  ICS files from Southwest Airlines don't import in Chrome, even using Incognito Mode.  Firefox works fine.  

marked this as an answer
Same here.  Just did the export and it worked in Edge but not in Chrome.  That doesn't make sense since Google Calendar is a Google Product so shouldn't it work in Chrome?
marked this as an answer
ICS file fully validates but cannot be uploaded with any browser with "Oops, we couldn't import this file..."
Tried chrome, firefox, safari, and Opera.

Other response is "Imported 0 out of 0 events. Unable to process your iCal/CSV file."
marked this as an answer
Same problem, same solution: it works with Edge. 
Google seems not to care much about this. Let alone that the user interface is far from logical: why is importing of calendar items a part of settings? Never to be found intuitively ... Will switch to something else, Google just eats up my time ...
marked this as an answer
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
Delete post?
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Unable to delete reply.
Removed from Answers
Marked as Recommended Answer
Removed recommendation
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Unable to lock
Unable to unlock
Unable to pin
Unable to unpin
Unable to mark
Reported as off topic