This content is likely not relevant anymore. Try searching or browse recent questions.
Huawei P20 google calendar doesn't sync 0 Recommended Answers 16 Replies 63 Upvotes
1 Recommended Answer
$0 Recommended Answers
I'm using Huawei P20 and could not see the events created on the phone on google calendar in the computer's calendar. But I see in the phone the events created on  the computer
All Replies (16)
Hi Kiril,
Are you using the official GCal app for Android?
Please press the 3-dots button on the top-right, and click Refresh. Afterwards check if you can see your events using the computer.
marked this as an answer
Still doesn't work even when using the original calender...
marked this as an answer
I'm having the same problem!
marked this as an answer
Hi Im facing the same issue.  Please help.
marked this as an answer
Same issue, with factory reset (all data and apps) i get working calendar.
marked this as an answer
me too, use to work but has stopped
marked this as an answer
Same issue, anyone found a fix?
marked this as an answer
Is your mail sync on? I noticed this problem occurs every time I put my phone offline (disabling wifi and disabling mobile data). If you want to reactivate the sync you have to open your Gmail-app on the phone, go to settings of your account and enable Gmail sync. After that the calendar syncs automatically again.
marked this as an answer
I also have the same problem! And when I delete events from my phone calendar, they delete from the computer but still appear in my phone! I've uninstalled and reinstalled the app, reset my phone and everything a million times to no avail. :(
marked this as an answer
I GOT IT!! listen to me! If U want to sync from Huawei Calendar from your mobile to Google Calendar and viceversa first U need to see if your mobile is on BATTERY SAFE MODE then is so U need ti CHANGE it ON MAXIMUM usage battery then everthing will go to normal ... stupid like that .. i don't know why but it work .. other thing U can do is go to setting > user account > Google > Sync now (but U need to do each time).

Italian do it better
marked this as an answer
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
Delete post?
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Unable to delete reply.
Removed from Answers
Marked as Recommended Answer
Removed recommendation
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Unable to lock
Unable to unlock
Unable to pin
Unable to unpin
Unable to mark
Reported as off topic