Currently, we're working with a limited support team. It may take longer than usual to connect with us. Thanks for your patience.

/business/community?hl=en
This content is likely not relevant anymore. Try searching or browse recent questions.
Uploaded photos not showing
0
Hello, I administrating in Google business veterinarian clinic. I uploaded new photos but these photos don't appear in public. Here is the link of business Vetperla https://www.google.com/search?q=vetperla&oq=vetperla&aqs=chrome..69i57j69i60l5.3254j0j7&sourceid=chrome&ie=UTF-8

Here is screen shoot of business account: https://snag.gy/dBzFJv.jpg
Details
Pinned
Locked
Latest Update Latest Updates (0)
Relevant Answer Relevant Answers (0)
All Replies (62)
Relevant Answer
Thanks for asking on Google My Business
 
The issue of photos not showing up after publishing them has been occurring for some other users. Sorry for the inconvenience. Not sure what is happening but, it seems to be random. Can you confirm that these photos that do not show up conform to the right specifications? I assume so, but please confirm that. Here is a link to the page regarding specifications for Google My Business photos.
Next step is to contact support directly so that they can investigate what is causing this. Here is how to get information to them. You can contact business support via one of these options and ask for help in getting verified:
 
Support is aware that sometimes this happens and they are working on fixing it. Anyone that has followed the social media escalation has gotten it fixed that I know of.  If not fixed by that means please post me back and I will escalate it internally. Please ask for a case number as you get contact from the support group for referance. It will speed things up.
For contacting a help group, you can use Google My Business Page help group on Twitter and Facebook pages to ask your question. The social help team is there to help from Monday - Friday 8a - 5p ET in the United States of America. Please ask for a case number and save it.  If it does not get resolved in a reasonable amount of time, please post back to me.
 
Thank you for asking,  
 
David W Cox  
marked this as an answer
Relevant Answer
Hey, tired to write message via Facebook around two weeks ago, also week ako directly via google. 

But still no response, could you help me?


Also we have one more very big issue. In same location used to be another vetclinic, yet in google bussines maps yet they still appears. Even tho no longer this business operates there.

Owner of that business don't have referrals to connect and remove it's address, so we would like to know what to do that our new business would be showed instead old one.


marked this as an answer
Relevant Answer
Hi, i have the same issue that you have so i contact them here: https://support.google.com/business/contact/business_c2c_l?from=cuf_c2c&visit_id=636772871176786948-1563848983&rd=2

They call you in the act, and as well they internally they reset my profile so the photos that was not showing automatically started to appear.
marked this as an answer
Relevant Answer
Hi, Lukas Marciulaitis
 
The link that Belen posted is a good one also depending on what group you get linked to. Social media links to facebook or twitter can take 24-48 hours to get responses.
 
The other part of your question I am trying to understand
The first listing you referred to Google Maps URL: https://www.google.com/maps?cid=17437977628403213105 is Veterinarijos diagnostikos ir gydymo centras. The address shows 
Aukštaičių g. 54, Kaunas 44163, Lithuania are you saying that is now run by someone else? 
 
The second listing Google Maps URL: https://www.google.com/maps?cid=17871471975969979893
is VETPERLA - Kauno veterinarijos klinika at Aukštaičių g. 54A, Kaunas 44163, Lithuania.
 
So now the two locations are seperate locations and both seem to be claimed listings. The person that has the login and password for the old account at 54, Kaunas 44163 would have to make the change. For them to run the listing you would have to transfere the ownership to them or they would have to go through the process of claiming the listing so they can manage it. It takes at least a week or more to do it.  If I need to clarify please post back.
 
 
Thanks For Asking,
 
David W Cox
 
If you find this response resolves the question, please mark this post as  “recommend” button. This action helps to keep the community organized and lets users know that the issue is resolved.
 
Find me at Davidwcox.com
 
Please be aware that this forum is content from volunteers. Not Google employees. Google Product Experts are advising on best practices and interpreting Google's policies based on their experience. The goal is to learn more and help users get the most out of Google products. Program information
 
marked this as an answer
Relevant Answer
I removed my "logo" picture and all of my other images showed up automatically. Try and see if that works for you.
marked this as an answer
Relevant Answer
Thanks.. it's working 😊
marked this as an answer
Relevant Answer
Hey, so the removal of the logo worked for my business too.
marked this as an answer
Relevant Answer
This is still happening. There is no logo up for the business in question so I couldn't use that fix. Talked to support and it still isn't fixed.
marked this as an answer
Relevant Answer
I was made a manager today for the site Wimberg Landscaping. I am following size requirements for photos but I do not see them on the public side.
marked this as an answer
Relevant Answer
Same issue here. I contacted support and was told they refreshed it and to wait 24-48 hours. It's been weeks now and still not showing. They told me to reply to their follow up email if I'm still having issues. I replied twice but they just ignore it I guess and haven't replied back. I also tried the deleting the logo hack/workaround several times but it did not work for me.

According to this thread and various other forums this has been a bug for over a year and they still haven't fixed it. This is absolutely pathetic especially for a company as big as google. As a developer myself it's mind boggling to me that they can't get such a simple thing fixed in over a year and it's pretty disconcerting as an Alphabet investor.
marked this as an answer
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
Report post
What type of post are you reporting?
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
/business/threads
//accounts.google.com/ServiceLogin
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Deleted
Unable to delete reply.
Removed from Answers
Removed from Updates
Marked as Recommended Answer
Marked as Update
Removed recommendation
Undo
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Locked
Unlocked
Unable to lock
Unable to unlock
Pinned
Unpinned
Unable to pin
Unable to unpin
Marked
Unmarked
Unable to mark
Reported as off topic
Known Issue
Fixed
Marked Fixed
Unmarked Fixed
Unable to mark fixed
Unable to unmark fixed
/profile/0
false
Search
Clear search
Close search
Google apps
Main menu
Search Help Center
true
99729
false