Blogger and browser compatibility

Here's a list of browsers and operating systems that work with Blogger.


  Windows XP/7 Linux (Ubuntu) MAC OSX 10.4 + Mac OSX 10.3.9 and below Windows 8/8.1
Google Chrome
Safari 4 +      
Internet Explorer 9*      
Internet Explorer 10*      
Firefox 3.6 +  

Note: Other browsers might work with Blogger. However, we can't guarantee that features will work as expected.

* For best results, turn off Compatibility View.

No matter what browser you use, here's what you need to do: