Compatible browser and operating systems

To use Blogger, your browser must allow cookies and have JavaScript turned on.

Compatible browsers and operating systems

Blogger works with the following browsers and operating systems:


  Windows XP/7 Linux (Ubuntu) MAC OSX 10.4 + Mac OSX 10.3.9 and below Windows 8/8.1
Google Chrome
Safari 4 +      
Internet Explorer 9*      
Internet Explorer 10*      
Firefox 3.6 +  

Older browsers might work with Blogger. But we can't guarantee that all of the Blogger features will work perfectly. For best results, make sure that you're using the latest version of your browser.

* For best results, turn off Compatibility View.

How helpful is this article:

Feedback recorded. Thanks!
  • Not at all helpful
  • Not very helpful
  • Somewhat helpful
  • Very helpful
  • Extremely helpful