/androidauto/community?hl=en
This content is likely not relevant anymore. Try searching or browse recent questions.
Android Auto Causes Pixel 3 XL to Restart Every Single Time - Doesn't work at all! 1 Recommended Answer 88 Replies 181 Upvotes
1 Update
$0 Updates
1 Recommended Answer
$0 Recommended Answers
1 Relevant Answer
$0 Relevant Answers
1
Since one of the latest updates in November or December my pixel 3 xl won't work with android auto anymore. Plugging my phone into android auto just causes the phone to reboot every time I do so. If I leave the cable plugged in, the phone will reboot then once I swipe up to unlock it will show the Google logo and reboot again repeatedly until I disconnect my phone from the cable. I have tried to boot into safe mode, which sort of works, I can connect my phone to the cable and use the phone still, but android auto never connects to the head unit at all.
Relevant Answer Relevant Answers (0)
All Replies (88)
Relevant Answer
Hi Alex, 
 
Thanks for reaching out to us.
 
Connectivity issues can occur due to several factors (e.g. car, phone, USB cable, software, etc) that can affect the performance of Android Auto. We recommend trying the troubleshooting steps on this FAQ thread to help with your experience.

If the issue still persists, you can fill out this Contact us form for further assistance. Thanks!
marked this as an answer
Relevant Answer
Hi,

Yes there are a number of factors I should've clarified that I have verified the cable is good by using a different phone with the same cable headunit etc and had no problem with android auto that way. I have also made sure my usb c port is clean which it appears to be.

I have already tried everything on the FAQ page, I have cleared cache for Google app, google play services, android auto and even uninstalled updates for android auto (since it's a system app now) and reinstalled the updates and tried and it still doesn't work. Something to note though is that yes, when I plug the cable into my phone it does indicate it is charging, however once I unlock the phone it will restart so I am unable to really change the usb communication preferences but I did try to set the default preference in developer options to be file transfer / android auto. However regardless of these changes to my phone it still crashes.
marked this as an answer
Relevant Answer
Sinds today i have a similar issue with my Samsung S20. Phone is up to date. 
When i connect it with the cable to Andoid Auto it will reboot 1 or 2 seconds later. Tried the S20 in safe mode but same issue. Rebooted the Andoid car unit but problem exist.. other USB cable and same problem.
The Samsung S10 of my wife still works perfect! 
What can be the problem?
marked this as an answer
Relevant Answer
My Note20 Ultra has started doing the same today.

Recently bought an Autokit USB dongle to enable Android Auto on my Android-based headunit. It worked fine initially, but tonight, this issue has started. My headunit and Autokit software has not received any updates. I can't remember when, but I have a feeling my phone received a general update a few days ago so possibly caused then.

If I plug my phone into the Autokit dongle, it vibrates and recognises the charger part... then it SOFT reboots.

I say soft reboot as the screen goes blank, then the Samsung logo appears and it reloads the lockscreen after a few moments. A normal hard reboot would cause it to go blank, vibrate, then show a Samsung Note20 Ultra powered by Android screen, followed by the Samsung screen, then the lockscreen.... so it's not doing the powered by Android screen suggesting its not necesarially shutting down, its just a portion that is crashing and restarting.

I hope that makes sense. I've tried hitting Clear All Data in the Android Auto developer options which seemingly does nothing. I've also asked it to forget all cars and reconnected, but it still crashed.

Any suggestions greatly welcome. I didn't have enough time or phone battery to do much more troubleshooting but will have another look tomorrow
marked this as an answer
Relevant Answer
S10e working fine now, thanks!

Chrome app was auto-updated to 17 feb version, AA app still 21 jan version 

For others with same issue, in Netherlands AA is not in the Play Store either but the update to Chrome was sufficient to get it all working again
marked this as an answer
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
Delete post?
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
Report post
What type of post are you reporting?
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
/androidauto/threads
//accounts.google.com/ServiceLogin
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Deleted
Unable to delete reply.
Removed from Answers
Removed from Updates
Marked as Recommended Answer
Marked as Update
Removed recommendation
Undo
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Locked
Unlocked
Unable to lock
Unable to unlock
Pinned
Unpinned
Unable to pin
Unable to unpin
Marked
Unmarked
Unable to mark
Reported as off topic
Known Issue
Fixed
Marked Fixed
Unmarked Fixed
Unable to mark fixed
Unable to unmark fixed
/androidauto/profile/0