/androidauto/community?hl=en
This content is likely not relevant anymore. Try searching or browse recent questions.
-
5/25/19
Switch between audio inputs stops android auto working properly 3 Recommended Answers 6 Replies 4 Upvotes
1 Recommended Answer
$0 Recommended Answers
Last edited 5/28/19
when i initially connect my phone, android auto works fine - music, voice commands etc. However, if I switch to another audio input, when i return to usb input (either using touch screen or steering wheel controls) android auto no longer works. the visuals all do as normal, but the sound doesnt come through. so, for example, you can see the track in spotify look like its playing but no sound, or if i try voice control the colour dots appear but i cant hear the google assistant. This has only been an issue since yesterday. I have tried reinstalling, clearing cache etc, and trying my wife's phone, but nothing seems to make any difference.

the other thing i have noticed is that the way AA interacts with the head unit is slightly different. Previously, if i was listening through android auto, but wanted to change to DAB radio, i simply pressed the home button on head unit then 'audio' and DAB was opened by default. Now it defaults to USB. I appreciate that AA plays through USB but this is different behaviour to before.

If i disable AA, the head unit seems to work fine, so i do think its an AA issue.

Reconnecting resets everything,  but dont really want to have to do this whilst driving if i can avoid it. i just want it to work as it did last week!

I have since Google searched and think there may have been a firmware update about the same time this issue started, could this be the culprit and how do I go back to an earlier version?

Vauxhall Insignia 2018, R 4.0 IntelliLink

Samsung Galaxy S9
All Replies (6)
6/3/19
But there does not appear to be a solution in these comments.... This is something that started happening this part year. Was working normally last summer..so much be related to an update but not sure when since I don't use navigation all the time..I don't think we can roll back android updates. I've tried reinstalling AA but that didn't do anything...any ideas that worked?
marked this as an answer
Helpful?
-
6/12/19
I had to Google how to downgrade Google play services. From memory I first had to search 'device admin apps' and make sure they were all unlocked. Then I disabled the Google play store (settings-apps-Google play store-disable). Then I uninstalled updates to Google play services (settings-apps-Google play services-3 dots in top right-uninstall updates).

Android auto worked fine since. The only thing is your apps don't get updated unless you re-enable Google play store and initiate updates, which itself risks updating Google play services, meaning having to do the above to get working again
marked this as an answer
Helpful?
6/14/19
I have the same issue with my galaxy a7 and J4 but my older J5 running Android 7 works fine.

Rolling back Google play services in not a viable solution
Last edited 6/14/19
marked this as an answer
Helpful?
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
Delete post?
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
/androidauto/threads
//accounts.google.com/ServiceLogin
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Deleted
Unable to delete reply.
Removed from Answers
Marked as Recommended Answer
Removed recommendation
Undo
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Locked
Unlocked
Unable to lock
Unable to unlock
Pinned
Unpinned
Unable to pin
Unable to unpin
Marked
Unmarked
Unable to mark
Reported as off topic
/androidauto/profile/0?hl=en