/androidauto/community?hl=en
This content is likely not relevant anymore. Try searching or browse recent questions.
-
Android Auto and Pixel 2XL - Keeps moving from File Transfer USB to connection to no transfer 1 Recommended Answer 80 Replies 156 Upvotes
1 Recommended Answer
$0 Recommended Answers
1 Relevant Answer
$0 Relevant Answers
I have recently bought a Volvo V90 with Android Auto Installed. I have been trying to connect my Pixel 2XL for the past week, without success. 

I have tried everything including cleaning the USB connectors. A grand total of 12 different cables including high end ones (Ankel, Google etc). Turned USB debugging on. Set File Transfer to default in developer settings. Reset to factory settings on both the car infotainment system and phone. Cleared Cache in... everything! etc etc.

Essentially every bit of advice you can find online, I have tried.

I have today tried all the android phones in my office; a total of 11. 3 of which are Pixel's. Surprise Surprise the only phones that didn't work are Pixel's - all running Android 10.

I think I have found the problem but I don't know how to fix it. When I plug the phone in, I have to change the USB connection preference to File Transfer / Android Auto (when I haven't made it default in developer setting). As soon as I launch Android Auto it sets it back to No Transfer and wont let me change it.

What is the solution here? I rely on AA for day to day work life - I need it to work.
Most Relevant Answer Most Relevant Answers (0)
All Replies (80)
Most Relevant Answer
Same problem, Google has not done anything for months on this. So many posts with this problem. This is not good customer service at all
marked this as an answer
Most relevant based on info available
Most Relevant Answer
I have a similar problem with my Pixel 2XL and Volvo XC40 constantly disconnecting. Someone will need to die in a car crash trying to reconnect their device before this is fixed, it seems. Volvo says talk to Google, Google says buy a new cable. Very frustrating.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Experiencing same issue, USB options greyed out. Android auto icon missing
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Similar issue here.  Pixel 2XL and 2017 Honda Pilot.  Android Auto worked for 1.5 years untill the updates last fall.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Same here... 

Switched from 4XL to Pixel 5. Android Auto always worked - with Pixel 3, 3XL, 4XL. 

With the new Pixel 5 the same issues as posted here appeared. 
Connect it via cable, nothing happens except that it charges for 2 seconds and then stops charging. It does this over and over again. 

Tried everything, nothing worked. 

Put my 4XL on, worked as always. 
A shame...
marked this as an answer
Most relevant based on info available
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
Delete post?
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
Report post
What type of post are you reporting?
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
/androidauto/threads
//accounts.google.com/ServiceLogin
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Deleted
Unable to delete reply.
Removed from Answers
Marked as Recommended Answer
Removed recommendation
Undo
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Locked
Unlocked
Unable to lock
Unable to unlock
Pinned
Unpinned
Unable to pin
Unable to unpin
Marked
Unmarked
Unable to mark
Reported as off topic
/androidauto/profile/0?hl=en