/androidauto/community?hl=en
This content is likely not relevant anymore. Try searching or browse recent questions.
-
3/16/19
Voice commands and text to speech won't work, but only for text messages 0 Recommended Answers 79 Replies 235 Upvotes
1 Recommended Answer
$0 Recommended Answers
Voice commands work fine on Android auto for everything except text messages. Text to speech won't work for text messages either. Used to work just fine, then stopped. Made sure all apps were updated to latest versions. Made sure Android auto had all relevant permissions enabled. Made sure Google services and text to speech all had full permissions. Made sure messages app had full permissions. Voice commands work for all other apps.

Android auto version: 4.0.590434
Vehicle: 2017 Chevy Colorado
OS version: 8.1.0
Huawei Nexus 6P
All Replies (79)
Hi Mario,

Thanks for reaching out. Could you give us an estimate to when this behavior began to appear? Have you tried clearing the cache for Auto and Play Services?

To do so:
Open phone Settings > Apps & notifications > Android Auto > Storage > Clear cache and clear data
Open phone Settings > Apps & notifications > Google Play services > Storage > Clear cache
marked this as an answer
Helpful?
-
3/19/19
Clearing the cache has made it possible to compose new texts via voice, so we have a partial victory there. However, reading texts still does not work. I press the play button next to a new text and I get the 4 Google color dots that just hang there as if expecting input, but no voice comes. Eventually they time out and the radio audio resumes.

Tough to say when this started as I usually ignore texts while I'm driving. Maybe a month or two ago?
marked this as an answer
Helpful?
3/22/19
I am unable to send any type of txt messages I wish I could post a video here. Everything goes fine until "are you ready to send it" once you say yes the response is "I am not sure how to help with that". Same issue for the past four months. Please I need to fix this somehow I can't be here reporting the same issue over and over again every week somebody please get back to me. I am using oneplus6t and even without connecting it to my car display just oppening AA app and pressing mike and trying to send a text gives same results. With every update I hope it will get fixed but it does not. Need help asap.
marked this as an answer
Helpful?
3/22/19
I have exactly the same issue on a Sony Xperia XZ1 for almost a year. This was the same on both Oreo and Pie. It last worked back in February 2018 but that old version on Android Auto no longer installs so can't roll back to it. I have tried all builds beginning with 3.5 onwards and none work.

Google assistant does voice texting flawlessly and as AA supposedly used Google Assistant now I don't understand what the issue could be.
Last edited 3/22/19
marked this as an answer
Helpful?
3/22/19
David Wallis said: "Google assistant does voice texting flawlessly and as AA supposedly used Google Assistant now I don't understand what the issue could be."

They key word in that sentence is SUPPOSEDLY  - you're making a big assumption there as obviously if they used the same engine they either both would work or both would not work for the same voice commands.

For many of us, AA is currently completely unreliable close to the point of being useless.
Last edited 3/22/19
marked this as an answer
Helpful?
3/24/19
Sprint LGG6 o/s 8.0 2018 Murano with AA

After 10 months of the same 'texting/speech/message' sending issue as experienced by so many others, it looks like my problems have been solved by the latest AA update (March 18 4.1.51xx) and Google update (March 1st 9.31.8.21) I'm 6 for 6 in requests and sending. Worked perfectly. Make sure your music sound volume is lowered. All other AA features continue to work also...as they always did. Hope this helps others.
marked this as an answer
Helpful?
3/26/19
Had same problem had to mirror my phone. It got turned off after an update...
Hope this helps
marked this as an answer
Helpful?
-
4/2/19
Any other AA team members have a solution for the continuing text to speech issue? Speech to text is working just fine. It's a 1-way issue as described in my earlier posts.
marked this as an answer
Helpful?
4/4/19
I'm also having the same issue as Mario T. Everything was working fine when I had my Galaxy S8. Once I got the Galaxy S10, Text to speech for text messages no longer worked. I click on the message on my car display screen, and it only shows this attached image. Please help us.
marked this as an answer
Helpful?
11/26/19
  • Error message: No error message
  • Are you using Android Auto on your phone screen or car’s display? Car's display
  • Does the issue occur outside of Android Auto app? No
  • Car / head unit make: 2019 Hyundai Elantra Value Edition
  • Phone make & model:  Galaxy S10+
  • Android OS version: 10
  • Google app version: (Settings > Apps (or Apps & notifications > App info) > Google) Google App Version 10.85.11.21.arm64
  • What did you say to Google? How was it recognized by Google? (You can check https://myactivity.google.com/myactivity) - I've said "Hey Google" or "OK Google" and it allows me to say the message, but closes before it asks me to send or change it.
marked this as an answer
Helpful?
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
Delete post?
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
/androidauto/threads
//accounts.google.com/ServiceLogin
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Deleted
Unable to delete reply.
Removed from Answers
Marked as Recommended Answer
Removed recommendation
Undo
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Locked
Unlocked
Unable to lock
Unable to unlock
Pinned
Unpinned
Unable to pin
Unable to unpin
Marked
Unmarked
Unable to mark
Reported as off topic
/androidauto/profile/0?hl=en