If you’ve been using the Android Auto app on your phone screen, you’ll need to switch to Google Assistant’s driving mode, a new integrated driving experience. If your car is compatible with Android Auto, you can still connect directly to your car’s display.  Learn about other ways Google is ready to make your drive better.

/androidauto/community?hl=en
This content is likely not relevant anymore. Try searching or browse recent questions.
Android Auto not connecting
2
Since recent update the app won’t connect to my phone via the usb cable.  I’ve tried multiple cables.  It won’t work for a bit if time and then all of a sudden it connects.  Fairly new Pixel 4a 5G.
Latest Update Latest Updates (0)
Relevant Answer Relevant Answers (0)
All Replies (44)
Relevant Answer
i am having a similar problem with a Samsung A11.  Android auto will not connect to my car anymore.  (Subaru BRZ 2018)
marked this as an answer
Relevant Answer
Same problem start from yesterday  i have try evrything 
Literly evrything in the pasy 24 hours . So sad  
I gave s9 plus  .   I have citroen c5 aircross if its mattwr   all apps are update. I
marked this as an answer
Relevant Answer
I am having a similar issue with my 2021 Ford F150. When I first got the truck in May 2021 my android auto worked perfectly both wirelessly and plugged in. Now into August BOTH wireless and wired do not work. It shows on my phone that I am connected but nothing shows up on my trucks screen nor any features. 

I am running Android Auto V6.7.612934 with Android 11 on my Google Pixel 4. I have tried multiple solutions I have read on forums and nothing seems to fix the problem. 

Please help, thank you!
marked this as an answer
Relevant Answer
Same problem since yesterday! 🥴
marked this as an answer
Relevant Answer
I have a 161 Skoda Actavia I went to the dealership to get Android Auto set up with maps it will connect to my phone and muscis bit cannot get maps  on tried everything
marked this as an answer
Relevant Answer
Same problem here only since last update. It keeps saying "no device connected" with a brand new OnePlus 8 & 2017 Honda Accord. 
Don't give me your useless canned response. Something is obviously broken. FIX THIS!
marked this as an answer
Relevant Answer
I have the same issue. We need it fixed.
marked this as an answer
Relevant Answer
Currently, when I plug my phone to my car via USB it starts charging but within seconds connection fails. Experience is the same with almost all kinds of cables.

Whereas those cables charge my phone when I plug them to a wall socket or laptop, they do not charge my phone in my car anymore.

My car's usb unit works fine with iPhone 8s and xiaomi mi 8 explorer that my sister owns; and both Apple car play and android auto works fine with those devices. However, I have read many comments from users having newer phones such as xiaomi mi 11, Samsung galaxy s20 etc. experiencing similar problems. 

When I clear the cache of Google apps and Android auto app it starts connecting again briefly; then connection fails again. I tried to turn off the battery optimization settings and even performed a factory reset as suggested but those did not work neither. The only way to connect my phone with my car is via bluetooth as I used to do 7-8 years ago. 

Thus, the problem does not stem neither from my car, nor from usb cables, nor from my phone's hardware. Apparently, it is a software problem that occurred just after new software updates of Google. It is unbelievable how can such a tech giant create such a big software fault that render phones-car connection useless. Immediate action required Google!!!
marked this as an answer
Relevant Answer
Same here. Since phoneupdate to Android 11 on Galaxy A41. Worked for  almost 6 years on several Android phones.
marked this as an answer
Relevant Answer
marked this as an answer
Relevant Answer
Hey Google. Fix the damn problem
marked this as an answer
Relevant Answer
I had no connection issues and gave up for over 12 months in my new mitsubishi pajero.constantly frustrated.Then only just a week ago had an idea i went into head unit bluetooth settings and switched off all bluetooth connections with my phone.Reinstalled android auto on phone plugged into unit and went thru grant permissions and let Android auto turn on bluetooth and now for 2 weeks have it running perfectly everytime i plug in and with full functionality.Turned out to be a simple setting in the head unit that was blocking the App.Big smiles from me.
Hope this will work for others frustrated with the app
marked this as an answer
Relevant Answer
Terrible last 2 months. Have changed my USB cable 3 times. Not the phone nor the cable. Cannot connect to car. All was OK the last 3 1/2 years. Fix the damn proble. Today, in the morning it worked about a minute and then shut off. Same tonight driving home. How can I delete the program and go back to an older version
marked this as an answer
Relevant Answer
I received the troubleshooting guide from Google through my email. I did follow to the T. Connected my USB to car. Was surprised it connected, chose my drive to address, then it crashed and could not connect anymore. Tried rebooting. removing the phone on HMMI, adding phone, about 5-6 times NOTHING

This is what I received from Google which did not work

Thanks for contacting the Android Auto support team. Please try the troubleshooting steps below and let us know if the issue persists.
  1. Go through the troubleshooting guides at My Android Auto app isn't working and Can’t connect or stay connected - How to diagnose/address the issue.
  2. Try removing the connected cars from the Android Auto Settings page. If you no longer see the Android Auto icon on your phone, please check this Help Center article for more information. You can also go to the Play Store and download Android Auto for Phone Screens, which is only available on Android 10 devices.
    1. Open Android Auto app > tap the left menu and go to Settings > Connected Cars > top right three-dot menu > Forget all cars > Tap Ok.
    2. Connect to your car display and re-enable Android Auto on your car.
  3. Please make sure to disable all battery power saving mode for the Android Auto app. 
    1. Phone Settings > Tap Battery > Adaptive Battery > Turn off Adaptive Battery.
    2. Phone Settings > Apps & notifications > Advanced > Special app access > Battery optimization > Tap the "Not optimized" dropdown menu > Select All Apps > Android Auto > Select Don't Optimize.
  4. Try restarting the phone device.
 
Thanks,
The Android Auto team
marked this as an answer
Relevant Answer
None of that works for me. It has also affected how some of my apps work on my phone.  How do I disable the do not disturb.  Quite frequently I used to be the plugged in phone as a passenger but still use my phone when it was displayed.
marked this as an answer
Relevant Answer
Hi everyone, 
 
Thanks for reporting this issue. We've forwarded your issue to the rest of the team. We'll reach out to you if we need more information. Thanks!
marked this as an answer
Relevant Answer
Same issue there.
Different phones (older Android version) works fine with car, but new one with ver. 11 never connected.
marked this as an answer
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
Report post
What type of post are you reporting?
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
/androidauto/threads
//accounts.google.com/ServiceLogin
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Deleted
Unable to delete reply.
Removed from Answers
Removed from Updates
Marked as Recommended Answer
Marked as Update
Removed recommendation
Undo
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Locked
Unlocked
Unable to lock
Unable to unlock
Pinned
Unpinned
Unable to pin
Unable to unpin
Marked
Unmarked
Unable to mark
Reported as off topic
Known Issue
Fixed
Marked Fixed
Unmarked Fixed
Unable to mark fixed
Unable to unmark fixed
/profile/0
false
Search
Clear search
Close search
Google apps
Main menu
Search Help Center
true
105835
false