/androidauto/community?hl=en
This content is likely not relevant anymore. Try searching or browse recent questions.
S21 Ultra - Android Auto crashes when the phone is unlocked
1
Galaxy S21 Ultra. After the constant nightmare AA has been on this device and trying one thousand cables, I finally got one that works... as long as I don't unlock the phone. If the phone is locked and I don't touch it, all good. If the phone is unlocked, all good. But if the phone is locked and I unlock it, Android Auto crashes and never recovers, I have to manually disconnect the cable and re connect again to launch AA.

I don't use any fancy security things, don't use third party launchers, themes, icons; nothing. No good lock, no Galaxy labs, anything; I come from an iPhone (and the total pain that AA is makes me regret leaving iOS every single day of my life) so I don't care for customization. The phone has a Samsung Calendar widget, I tried deleting it and it's the same. It's just broken for no reason, and it can't be the cable, it works fine If I don't unlock.

I also tried re installing AA, Webview, Chrome, using Canary WebView and Chrome... nothing works.
Latest Update Latest Updates (0)
Relevant Answer Relevant Answers (0)
All Replies (103)
Relevant Answer
Hi Gabe,
 
Thanks for reaching out to us.
 
Connectivity issues can occur due to several factors (car, phone, USB cable, software, etc) that can affect the performance of Android Auto. We recommend trying the troubleshooting steps on this FAQ thread to help with your experience.
 
If the issue still persists, you can fill out this Contact us form for further assistance. Thanks!
Recommend
marked this as an answer
Relevant Answer
Hello! Yes, I tried every one of those steps. And as I said, Android Auto works as long as I don’t unlock the phone. If its locked or unlocked it will work for hours, no problem.

But if the phone locks and I have to unlock it, AA crashes and I have to reset the cable. Everything in that FAQ is fine… as long as I don’t unlock.
marked this as an answer
Relevant Answer
Hello,

I also have the same problem as Gabe after the last 2 updates, on Samsung Galaxy S21.

Up until March everything was working properly. 

After the last 2 updates, as soon as I unlock the phone connected to Android Auto, the application goes to Crash. The only way to get it working again is to unplug and re-plug the cable.

I have already changed the cable by putting an original Samsung one. Nothing has changed.
marked this as an answer
Relevant Answer
Same thing here. 2018 GMC Canyon and S21 Ultra (wired). Gone through all the troubleshooting steps posted already. Tried different cables, different ports, different default USB setting. Every time AA crashes when phone is unlocked. This started only this past week for me that I've noticed.
marked this as an answer
Relevant Answer
Gotta love the standard helpful responses from Google
marked this as an answer
Relevant Answer
After the last update that I have received yesterday I have the same issue with a s 20 plus 5g and a tucson 2019. Until yesterday I had no problems. The cable is not the issue
marked this as an answer
Relevant Answer
Same thing here with the S21 5G US version, after the latest update, everything was smooth before that.
marked this as an answer
Relevant Answer
Same issue here, with my S21 Ultra in my 2019 Civic Type R. Except mine will *usually* reconnect itself and work fine. Occasionally it does not, and sometimes the head unit will tell me that the device I have connected isn't compatible with Android Auto. All this started since my update yesterday I believe. It's incredibly frustrating. I get the various phone and vehicle manufacturers can complicate things, but damn.
marked this as an answer
Relevant Answer
Thank goodness I'm not the only one having this issue. 

US Unlocked S21 Ultra here using Android Auto with a 2021 Chevy Silverado. This annoying issue started after receiving the May 2021 security patch last week. Just like everyone else, if I unlock the phone while AA is running, it crashes and I have to disconnect and reconnect the cable to get it running again.
marked this as an answer
Relevant Answer
Hey everyone,
 
Thanks for reporting this issue. We forwarded this issue to the rest of the team. We'll update with more information when it's available. Thanks!
marked this as an answer
Relevant Answer
I can't even get my s21 to connect with android auto through USB TO my kenwood ddx9018dabs it just keeps saying to accept terms and conditions but I can't find it anywhere but my s9 I had not one problem with it
marked this as an answer
Relevant Answer
Same here .. brand new S21+ and Google Mapa on AA is not working at all .. I ended up switching to Waze.
marked this as an answer
Relevant Answer
I have the S20 Ultra model and having the same issue. Done all the troubleshooting steps. Only difference for me is after moment it will reconnect, but the fact it disconnects if I unlock is very inconvenient as sometimes I need to do so or my co-pilot needs to and that causes disruption for maps or music
marked this as an answer
Relevant Answer
Same here, S10+ latest official, AA 6.4.611714-release, Ford Sync 3.0 . 

Doing so for about a week (or some more). At phone unlock, AA is crashing to Sync interface, and phone is asking for permissions in order to start Android Auto again (need to press Allow, otherwise AA will not start!)

Thanks!
marked this as an answer
Relevant Answer
Same issue here, note 20 ultra 5g. Been about a week. its not the solutions that are suggested, its a bug.  It would be great if this forum Could be a central location for us to look instead of getting vague responses that just sit from support that we've already tried.  

This 'where's Waldo' hunting and poking around the internet for solutions to bugs that are thrown at our phones is getting old. My last frustration was the one where we had to go in to car interface and set to use phone ringtone so my phone would ring again which I ended up finding somewhere else on the Internet and I should have found the solution on this form.
marked this as an answer
Relevant Answer
I've been having this same issue over the last two weeks. I have a note 20 ultra connected to a 2020 Sentra. I have used both USB and usb-c wires in the car. It actually started happening after a recent Samsung update. I uninstalled android auto and reinstalled it. I deleted the Bluetooth connections on both phone and car and set everything up from scratch and it still disconnects from the car the second I unlock my phone so music and gps disappear off my car screen.

I've had the phone and car since last year and had no problems until recently.
marked this as an answer
Relevant Answer
I'm having this issue too in Australia with my Samsung note 20 ultra Snapdragon version from HK in a 2018 Hyundai Tucson. These responses from Google is not helping what so ever troubleshooting is only good if it works, everyone is constantly having problems and problems still remain after this troubleshooting response. Maybe troubleshoot the troubleshooting you've got and actually help people still having problems and get a team to fix it. This is actually a very serious safety hazard if android auto glitches out because let's say your passenger unlocked your phone to contact emergency services and your cars screen with the map location turns off having a passenger or driver become lost. It's not good. Please update the app for Samsung's in mind. 

I have a feeling it's a Hyundai/Samsung S20 and S21 series phones having this issue more common.
marked this as an answer
Relevant Answer
 After updating AA on my Samsung a71, AA constantly restarts indefinitely, now it has stopped starting.  cadillac cue 2.5
marked this as an answer
Relevant Answer
Same problem with Skoda and Samsung S20+ 5G after last phone update.
All the time when I unlock phone AA is disconnecting.
marked this as an answer
Relevant Answer
I'm having the same issue as well with a regular S21 with the latest updates to android auto. I've got a Hyundai sonata which also seems to have an issue with the s21 where it stops responding 5-10 min after launching Android auto.
marked this as an answer
Relevant Answer
Hi, I'm having the same issue, since last may update on my S21 Ultra - Exynos edition and Volvo XC60. S21-AA relation is a pain in the ***. Just before that i bought 4 different cables to connect my phone to the car because all of them were unstable. 

I never had any of these issues with my previous Huawei Mate 20 pro. 

Come on Google, you have a lot of work to do. Android Auto is a selling point. If I knew that it's gonna be so hard to enjoy having phone on my car I would chose to buy without hesitation an Iphone.

Thank you.
marked this as an answer
Relevant Answer
I am also having this issue since the last update on my galaxy note 20 ultra
marked this as an answer
Relevant Answer
Same problem on S20 FE
marked this as an answer
Relevant Answer
I am having the same issue as well on my Note 20 Ultra with Uconnect 8.4
Error 8 red screen.
Tried adjusting clocks, new cord, clearing cache to no avail.
marked this as an answer
Relevant Answer
Same problem
marked this as an answer
Relevant Answer
Same problem too, mine is S21 Ultra 5G use on 2017 Civic SI, everything was smooth until the last system updated. Problem is usually happened when using lane watch, music apps are start lagging then AA is disconnected. I have to reconnect cable again.
marked this as an answer
Relevant Answer
Same problem. Note 10, AA not working, after last update keeps stopping every time I unlock screen.
marked this as an answer
Relevant Answer
Same problem here .
Note 20 ultra Snapdragon version with Hyundai Santa Fe 2019 Canada.
This is so frustrating. Was never an issue before this.
It maybe Samsung or Hyundai but AA got to find a solution to this.
Thanks
marked this as an answer
Relevant Answer
I guess it's more Samsung issue because when I plug in another android device like one plus . It works perfectly with the Hyundai so it's Samsung . Lemme know if anyone can find a fix for this.
Thanks
marked this as an answer
Relevant Answer
Hi,

I got the same issue with Galaxy S21U Exynos model - May update and last AA update. So frustrating
marked this as an answer
Relevant Answer
Dears, good day!

Same here. Everything works just fine with the phone status "locked" or "unlocked". The problem only occurs with the action of unlocking the phone.

I've inclusive tested with my friend's car's Display, to see if the problem were my display. But the problem remains.

Please solve this asap, it is really frustating and ruins part of the experience with the application. Thanks!

Phone: Samsung Galaxy S10
Android version: 11
One UI version: 3.1
AA Release: 6.4.611734
marked this as an answer
Relevant Answer
I'm using Note10+ model and same issue. When will it be fixed?
marked this as an answer
Relevant Answer
S21 Ultra, Civic 2018, Beta Android Auto and same issue. Tried everything and more, this is an Android Auto bug.

Please fix this and stop pushing us towards an easier situation like Car Play... this is getting sad.
marked this as an answer
Relevant Answer
Hi All, 

Thanks for all the reports. We informed the Samsung team and they have  applied a fix on an upcoming upgrade as part of the regular July maintenance release to resolve this issue. Please keep checking for system updates on the device.

Thanks
The Android Auto Team
marked this as an answer
Relevant Answer
S10+ : August '21 update seems to fix it. Will monitor.
marked this as an answer
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
Report post
What type of post are you reporting?
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
/androidauto/threads
//accounts.google.com/ServiceLogin
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Deleted
Unable to delete reply.
Removed from Answers
Removed from Updates
Marked as Recommended Answer
Marked as Update
Removed recommendation
Undo
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Locked
Unlocked
Unable to lock
Unable to unlock
Pinned
Unpinned
Unable to pin
Unable to unpin
Marked
Unmarked
Unable to mark
Reported as off topic
Known Issue
Fixed
Marked Fixed
Unmarked Fixed
Unable to mark fixed
Unable to unmark fixed
/profile/0
false
Search
Clear search
Close search
Google apps
Main menu
Search Help Center
true
105835