/androidauto/community?hl=en
This content is likely not relevant anymore. Try searching or browse recent questions.
This post is a trending issue.
Why Android auto is reading my text messages in English when everything on my phone is set to french
2
Hello everyone,
I'm french, I have a galaxy s10 in french, I use Android auto in french but when I receive a text message Mrs Google switch to English and try to read the name of the expeditor and the message in English even if it's in French.
It's hilarious but not very understandable.

When I receive text messages from telegram, everything is in French as wanted.

Did someone have this kind of issue? Some ideas

Thanks
Details
Pinned
Locked
Latest Update Latest Updates (0)
Relevant Answer Relevant Answers (0)
All Replies (1006)
Relevant Answer
Hi Cindy,
 
Thank you for reaching out. You could add another language by launching Android Auto App > Settings > Google Assistant  > Assistant tab > Languages > Choose language. Let us know if this works. Thanks! 
 
marked this as an answer
Relevant Answer
Hi
It's already set as french in this parameter. No change.
marked this as an answer
Relevant Answer
Same thing for me! I want my message read in french, but keep my s10 in english
marked this as an answer
Relevant Answer
Same problem. Phone is set in English and I want to keep it this way. Google assistant accepts both languages for commands and sometimes reads my messages in the right language, but when using Android Auto it only reads them in English.
marked this as an answer
Relevant Answer
It would be great at least to set the  default language for reading messages, of not able to detect autonomously.
In my case I have my phone in English (more features with google) but I receive messages in Italian and I reply in Italian as well.
I have many issues to understand the language I should use with android auto (I have set assistant in Italian but it not always works)
marked this as an answer
Relevant Answer
Same here. I want to keep my primary language to English but I want Android Auto to either (1) detect the language of the messages or (2) be able to choose the language explicitly. Most of my text are indeed in Italian. Any hint?
marked this as an answer
Relevant Answer
I already changed my settings as above but the issue still remains. Any further updates?
I'm using Samsung Galaxy Note 10 with Kia Forte (2019)
marked this as an answer
Relevant Answer
Did anyone find a solution for this issue? I have the same problem with my S10 reading texts in English, even though it's set to Danish in Android Auto.
marked this as an answer
Relevant Answer
I'm having the opposite problem. My languages are set for English and German but I'm getting some messages read to me in French.
marked this as an answer
Relevant Answer
Same issue for me in Android !! read sms in english instead french !
marked this as an answer
Relevant Answer
I have got the same problem. I wish it could recognise language of message automatically. At the moments it turns to read everything in English, however it responds to voice commands in Polish or English... very conusing
marked this as an answer
Relevant Answer
Same problem here. Chinese text messages or wechat messages were read in English pronunciation. This started sometime in this summer or fall. It was perfect before. I regret updating the app. If I remove the English from the Google assistant as suggested by the Community Specialist, Android Auto doesn't know what to do with the messages, saying it is still learning.
marked this as an answer
Relevant Answer
Dutch language set on my Android Auto, and reads whatsapp in English...
marked this as an answer
Relevant Answer
Same here for Dutch, but my phone is set to English which I would love to keep this way.... Would be nice to be able and set the primary language of the assistant...
marked this as an answer
Relevant Answer
+1. phone lang - english, messages - russian.
marked this as an answer
Relevant Answer
Same issue here. Phone is in English and android auto reads WhatsApp messages that I receive in Spanish using English. Impossible to understand.
marked this as an answer
Relevant Answer
Same issue here. Setting is in Dutch, auto reads messages in English
marked this as an answer
Relevant Answer
And same issue for me, Google, please help! :)
marked this as an answer
Relevant Answer
I have the same issue. My phone is in English but I want to use Spanish for reading messages. Please help!
marked this as an answer
Relevant Answer
same here, phone in english, responds to english and german, but would read german messages english. not usable that way.
marked this as an answer
Relevant Answer
Same here, all in my phone is in português , but Android auto read in English :(
marked this as an answer
Relevant Answer
This has been a problem forever, when will you fix it?
marked this as an answer
Relevant Answer
Same here, all in my phone is in português , but Android auto read in English  WhatsApp messages.

Don't have fix?
marked this as an answer
Relevant Answer
Also here, my device is in portuguese but the messages are all read in english. Funny enough other things like Turn-by-turn navigation are (correctly) in portuguese
marked this as an answer
Relevant Answer
Same here. Language device (and google settings) in Portuguese,  but whatsapp messages are all read in English
marked this as an answer
Relevant Answer
I have the same problem here in Portuguese
marked this as an answer
Relevant Answer
Same problem here...
marked this as an answer
Relevant Answer
Mesmo problema comigo, está configurado em português e reproduz uma mensagem em inglês. Alguém conseguiu resolver? Obrigado !!
marked this as an answer
Relevant Answer
Configurado em português, quis dizer.👆
marked this as an answer
Relevant Answer
Another Brazilian having issues with the WhatsApp messages. Everything is set to Brazilian Portuguese, but Android Auto reads my WhatsApp messages in English.
marked this as an answer
Relevant Answer
Same problem in Polish. Voice commands work ok in Polish, but read received messages in English only
marked this as an answer
Relevant Answer
Same problem. 

Everything is set to Brazilian Portuguese, but Android Auto reads my WhatsApp messages in English.

Error message: None

Are you using Android Auto on your phone screen or car’s display? Vehicle Display

Car / head unit make & model:  Caska


Phone make & model: Samsung Galaxy s10+

Android OS version: Android 10 - Security Patch level: January 1, 2020

Android Auto app version: 5.0.500224

Google Play services version: 20.04.12 (120400-290691535)

Messaging app name & version: Whatsapp 2.20.21 beta

Google App version 10.94.8.21
marked this as an answer
Relevant Answer
Mimi's answer do not work at all. I tried changing from dozends of languages an every time it only reads in english.

The message itself is in portuguese, but the pronunciation is in english.

Phone Make & model: Motorola Moto Z³ Play
Android OS version: 9 - Security Patch: November 1, 2019
Android Auto version 5.0.500224
Google Play Services 20.1.04 (100408-288960190)
Message app: SMS, (Facebook) Messanger and Telegram
Google App version: 10.93.13.21.arm64
marked this as an answer
Relevant Answer
Same problem....  I have the phone set in Spanish, and the Google assistant of android auto replies in Spanish with English accent,  so the commands are not understand.  If I use voice assistance with the phone not running android auto,  it works perfectly
marked this as an answer
Relevant Answer
Same problem here. Language pt-br and readiing messages in english. (whatsapp and messages)
Phone and AndroidAuto. 
When I start using The Android Auto, everything was right, but after few days The bug showed itself. 

Phone: Xaomi redmi note 7 
MIUI GLOBAL 11.0.4
ANDROID : 9PKQ1.180904.001
marked this as an answer
Relevant Answer
same problem.... any news?
marked this as an answer
Relevant Answer
My phone is set to Polish language, the only Assistant language is set to Polish and when I receive an SMS in my car, it's read using English pronunciation even though the text is in Polish.

Android Auto used to work quite well a year ago. Each subsequent version brings more bugs. Sometimes it's also updates to Google App or Google Assistant that break things. It's unbelievable that a company the size of Google can't get this under control. Most of posts on this forum is ignored completely. This product is dangerous to use while driving because of its bugs. Sad.
marked this as an answer
Relevant Answer
Same problem here. Language pt-br and readiing messages in english. 

Configs language, accessibility and Google assistant are set to pt-br

Phone: Xaomi MI 8 LITE 
MIUI: 11.0.8
ANDROID : 9PKQ1.180904.001
marked this as an answer
Relevant Answer
The same problem. All set to Polish, navigation works in Polish, but messages are still read in English.
marked this as an answer
Relevant Answer
Same problem here.
marked this as an answer
Relevant Answer
Same issue here and looks like the support team hasn't yet found a solution. Android Auto is reading my text messages in English when everything on my phone is set to Portuguese!!!!!!! HELP!
marked this as an answer
Relevant Answer
Same  problem:(
marked this as an answer
Relevant Answer
I've use to have text messages and WhatsApp messages that are read in Portuguese and sundnely all has changed to English!
marked this as an answer
Relevant Answer
Hi! 

I have same problem for a while, my Galaxy S9 has not been able to read incoming messages in the default Hungarian language. Hungarian text messages or FB Messenger or others messages were read in English pronunciation. In Android Auto App > Settings > Google Assistant  > Assistant tab > Languages > Choose language the Hungarian language unavailable, but previously worked the Hungarian TTS. Voice commands works right in Hungarian. I tried few earlier AA versions but unsuccessfully. I tried my phone and my Ford Sync 3 entertainment, other phone and other car to. 

Please help us!

Thank you!
marked this as an answer
Relevant Answer
Mesmo problema aqui, alguma solução?
Idioma pt-br reproduzindo em inglês
marked this as an answer
Relevant Answer
I find it very strange to have no response from the Google Team, it seems that no one reads the messages.  Bugs like this make Android Auto less secure, needing an urgent fix.
marked this as an answer
Relevant Answer
Same problem here and it starts few days ago.
Without changing any settings AA starts to read my messages with english, instead of finnish. Google assistant works otherwise with finnish and for example google maps navigation guidance is in finnish language.
marked this as an answer
Relevant Answer
Looks like that android auto is a third class product and Google does not care about it and its users.
marked this as an answer
Relevant Answer
Same with my Motorola, Phone in Portuguese, Google Assistant in Portuguese, but Android Auto messages in English.
Before the last update, in my old Phone l didn't have this issue.
marked this as an answer
Relevant Answer
I found what's causing the issue. It is the "Google" app. 

I went to the phone settings -> apps -> selected the "Google" app and then I removed all app updates for the "Google" app (from ... menu). Now messages are read in the correct language. However, once I update the "Google" app everything is messed up again.

This is a temporary solution, but hopefully, the "Google" app will be repaired soon and everything will get back to normal. For now, I'm keeping the "Google" app out of updates.
marked this as an answer
Relevant Answer
Thank you Maciej
marked this as an answer
Relevant Answer
In order not to be too outdated, I installed the App Mirror version 10.92.9.21 beta.  It is working correctly.  It is necessary to give the permissions again on the cell phone to the Assistant.
marked this as an answer
Relevant Answer
Thank you, Maciej! It works! Now we have to wait and see if Google will fix this annoying problem.
marked this as an answer
Relevant Answer
Thank You Maciej
marked this as an answer
Relevant Answer
Same here, everything in Portuguese, but messages are being read in English. Google, please fix it.
marked this as an answer
Relevant Answer
Hi everyone,

Thanks for the reports. The Assistant team is aware of this issue and currently investigating. We'll share more updates on this thread. Thanks!
marked this as an answer
Relevant Answer
Hi, I had the same problem with english reading. I went back with google app to version 10.92.12.21 and it again works.
marked this as an answer
Relevant Answer
Maciej Berniak points me to right direction
marked this as an answer
Relevant Answer
Same problem here and with all my friends. Google please fix this quickly!
marked this as an answer
Relevant Answer
Just started having this issue. My phone is in English, so I use Tasker + AutoInput to change my locale to Portuguese when connected to my car.

Up until a couple of weeks ago this was working perfectly, and all my messages were being read in Portuguese. But now though all the messages and the interface is in Portuguese, the Assistant is reading the received Whatsapp messages in English.
marked this as an answer
Relevant Answer
Removing Google app updates for the time being solved this for me. App had over 500Mb size and after removing updates there was a few Mb left. I dont see any bad effect on anything.. Yet.
marked this as an answer
Relevant Answer
Same here. I'm Polish, my phone is set to Polish, obviously all my incoming messages, both WhatsApp and text messages are in Polish and on Android Auto, the Assistant reads them as if they were in English. I tried wiping the app data, both in Android Auto and Assistant, tried to wipe cache but to no avail. Please fix this guys.
marked this as an answer
Relevant Answer
Same herre. Reading in English instead of the language set.
marked this as an answer
Relevant Answer
Same here, sounds funny, but unusable
marked this as an answer
Relevant Answer
Hi,

In Poland , google assistant read messages in english. Only in android auto.
marked this as an answer
Relevant Answer
Same here!
Google Assistant set to PT-PT, Android Auto reads messages in English.
It was working perfectly before. :/
marked this as an answer
Relevant Answer
Same problem...
My android auto read all messages in english. But my phone is set in spanish
marked this as an answer
Relevant Answer
The original message was posted in July/2019 and the only response we have is "we're looking into it".
That's not enough. For now the only way to fix this is to remove all the Google app updates, but that's lame. I want to have my phone updated and running.
marked this as an answer
Relevant Answer
I have exactly the same situation that everyone is reporting. Insane is that we still don't have this situation solved and it seems not being take care as a priority and we continue to wait for a solution...
marked this as an answer
Relevant Answer
If I ask my android auto a  random question it replies in a language that sounds Korean or similar.
If I ask it to call someone it replies in English, which is what the language is set to.
marked this as an answer
Relevant Answer
Remove  all updates for "Google" app.  Download and install "Google" app  version "10.92.9.21 beta" apk from apkmirror.com
Worked for me!
marked this as an answer
Relevant Answer
I am having the same issue. Phone is in Danish, but messages are read in English voice. It works fine when I uninstall updates from the app Google. But returns to English when I reinstall updates.

Thank you for giving me the tip about the app Google.
marked this as an answer
Relevant Answer
Same issue for me. It used to speaks in Turkish but after updated it reads the messages in only English.
marked this as an answer
Relevant Answer
Same here, assistant set to portuguese... messages are read in English
marked this as an answer
Relevant Answer
Same problem here, my cellphone set in Portuguese, but Android Auto don't read Whatsapp messages in Portuguese, only in English.
marked this as an answer
Relevant Answer
hi google, any news about this issue?
marked this as an answer
Relevant Answer
Same problem here. Reading my messages in English when my language is set to Brazilian Portuguese
marked this as an answer
Relevant Answer
As workaround by now you can:
     - deactivate Google App automatic updates;
     - remove the updates from Google App;
     - Install Google App 10.92.9.21 from apkmirror.com

works like a charm. you also might want to subscribe to this thread so you'll get an official update from Google/Community Specialist when the issue is solved.
marked this as an answer
Relevant Answer
Gratulacje, 15 lat Map Google, ale zepsute wiadomości SMS w samochodzie z Androidem, zamiast czytać je w moim języku polskim, czytasz je w cholara. Łączne pogorszenie usług jest coraz gorsze !!!!!!!!!!!!!!!!!!!!!
marked this as an answer
Relevant Answer
Dokładnie, u mnie to samo
marked this as an answer
Relevant Answer
I have the same issue!
My language is portuguese and all text messages are being read in english accent!!
marked this as an answer
Relevant Answer
15 Years Google Maps Aniversary and so many Bugs in AA.  Shame google.
marked this as an answer
Relevant Answer
Same problema
marked this as an answer
Relevant Answer
Same issue. Old beta version solves but why not use an up-to-date version? Hope this is fixed quickly.
marked this as an answer
Relevant Answer
Same problem with Danish when reading out text messages in Android auto which is now in English. Language setting in Assistant is Danish. Worked perfectly until recently.
marked this as an answer
Relevant Answer
Same for me. Read Portuguese text with English accent. Impossible to understand
marked this as an answer
Relevant Answer
Same issue in Poland. Impossible to understand what the voice is reading. Unusable feature at that time.
marked this as an answer
Relevant Answer
Em portugues acontece o mesmo lê as mensagens em inglês
marked this as an answer
Relevant Answer
Same problem here.
marked this as an answer
Relevant Answer
"Ok Google!" Same problem here. Samsung Galaxy s7 in Spanish. AA tries to read messages in English. Also, sometimes, when I give a voice command in Spanish, AA says something like "sorry I don't understand" (in English). Please solve. It is very annoying and makes reading messages unusable.
marked this as an answer
Relevant Answer
Same problem in Brazilian VW Polo. When i play the Whatsapp message the assistent read it in english, not in portuguese. I use a Samsung A70 with Android Auto.
marked this as an answer
Relevant Answer
Mesmo problema com meu S10 Plus, com toda a configuração em português. Sem alterar qualquer configuração, o sistema, depois de uma atualização, começou a responder em inglês mensagens de texto e whatsapp. Os demais comandos, como música, ligação, resposta de mensagem etc continuado lendo corretamente em português. Somente a leitura de mensagens recebidas de SMS e whatsapp, assim como descrição dos emojis, estão sendo lindas em inglês.
marked this as an answer
Relevant Answer
Same problem in Brazilian Portuguese, as already reported. This feature is useless in my language without a bug fix for this issue.
marked this as an answer
Relevant Answer
Google, any solution?
feature is unusable
marked this as an answer
Relevant Answer
Any update Google?
marked this as an answer
Relevant Answer
I have the same problem, Google assistant is set to portuguese (Brasil) but is reading messages in english in a very bizzare accent!
marked this as an answer
Relevant Answer
I have the same problem, Google assistant is set to Spanish but is reading messages in english.
marked this as an answer
Relevant Answer
Same thing in Portuguese. After the last update, the android auto stop reading the texts in Portuguese and begin to read it in English. The set up is Portuguese.
marked this as an answer
Relevant Answer
Same thing in Hindi, Google used to read my messages in Indian English, now I have to suffer American English (not even British English).
Something changed around a week or two ago.

Ideally it would read them in Hindi.
marked this as an answer
Relevant Answer
Hey google... Any update?
marked this as an answer
Relevant Answer
Hi all,

Thanks for all the responses. We recommend checking your ‘Voice’ language settings are properly set. Please follow the instructions below and let us know if the issue persists. Thanks!
  1. On your phone > Open Google app
  2. Select the bottom three dot tab More > Settings > Voice > Languages
  3. Set your primary language preference (Remove additional language (e.g. English) entries if they are enabled)
marked this as an answer
Relevant Answer
We've already done that. Please provide us with the real solution.
marked this as an answer
Relevant Answer
Only Portuguese language is set. No secundary languages.

Messages are readed in English.
marked this as an answer
Relevant Answer
I've already tried that (I think everyone here did that already) and it didn't work. The only temporary solution was disabling auto update and uninstalling all Google App updates.
marked this as an answer
Relevant Answer
A solução indicada não funcionou. Pelo que pude ver na longa lista aqui, literalmente o mundo inteiro tem o mesmo problema. 
Acho que ao invés de encaminhar e-mails automáticos vocês poderiam apresentar a solução, ainda que seja voltar à versão anterior, o que acham?
marked this as an answer
Relevant Answer
Fiz todos os procedimentos recomendados, mas permaneceu o problema.
Continua sendo lidas a mensagem de texto e whatsapp em inglês, apesar de só haver a língua Português (Brasil) cadastrada.
Aguardo uma solução.
marked this as an answer
Relevant Answer
the language was already set to Français Canada only, no other language selected.  So, no change, it still tries to read the text messages in english
marked this as an answer
Relevant Answer
For an issue raised more than 1 month impacting a lot of users around the world this is the solution provided ? More basic solution it should be impossible. Can someone prioritize and escalate to appropriate team and update all of us at least each 2 days. Thank you.
marked this as an answer
Relevant Answer
The suggestion suggested by Paul didnt work,  because in the settings of the Google app my native language was already marked
marked this as an answer
Relevant Answer
Hello. Thanks for your reponse. I tried the suggested setup and it did not work. The only way I was successful in having the assistant reading messages in spanish in Android Auto was by setting the main language of the phone to Spanish and deleting all English language options. The downside of this is that all the OS options are now in spanish and that's not what I wanted. I want the phone OS and commands to be in English and have Android Auto read the messages in Spanish. I think most of the people that posted in this thread wanted the same thing.
Any ideas?

Thanks again,
marked this as an answer
Relevant Answer
Boa noite.
Eu já tinha tentado toda a configuração indicada pelo Paul, mas não tinha dado certo.
Tentei, hoje, mudar meu celular para Inglês, e, então, as mensagens foram lidas em inglês.
Ao tentar colocar em espanhol ou português de Portugal, a leitura das mensagens do WHATSAPP continuou em inglês. 
Gostava muito do ANDROID AUTO. Já estou começando a me arrepender de ter comprado um Samsung S10e.
marked this as an answer
Relevant Answer
Paul, we all have done that with no help. Besides phones usually automaticly use the set language as voice so no need to even check. Please provide real solution and no this kind of crap and thinking users are stupid.
So far only way to get around this is to remove Google updates.
marked this as an answer