Update GPT library to prevent revenue impact

Starting on September 3, ad serving may be suspended until you implement the latest version of the GPT JavaScript library.

The latest release of the Google Publisher Tag library addresses a vulnerability that posed a potential security risk for earlier versions.

We believe one or more of your sites may use locally saved versions of the GPT JavaScript library, which is subject to a security vulnerability. Please review your sites and take action to integrate the latest version of the GPT library. 

We strongly recommend against serving cached versions of gpt.js, gpt_mobile.js or pubads_impl_XX.js from your server as part of our implementation guidelines. This is because locally saved versions of the JavaScript library are not automatically updated with new features and improvements, such as security patches.

What should I do?

If one or more of your sites use locally saved versions of the GPT JavaScript library, please update your site(s) urgently to integrate the latest version of our GPT JavaScript library.

To do so, your pages should refer to the GPT library hosted by Ad Manager at https://securepubads.g.doubleclick.net/tag/js/gpt.js.

For example:

<script async="async" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js">

This will enable Google to better safeguard your site(s) from security risks.

Was this helpful?
How can we improve it?