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Duet AI 现已更名为 Google Workspace 专用 Gemini。了解详情

查看自动配置错误

为基于 SAML 的应用设置自动配置时,您可能会看到以下错误:

请阅读以下内容,了解如何调试和解决这些错误。

注意:如果此处所述步骤无法解决问题,请致电支持人员。

配置时间失败

授权代码错误

当授权代码不能转换成刷新令牌时,则会出现此错误。如果您的授权代码错误,或者如果您在授权之后,等待了过长的时间才点击保存更改,则可能会发生这种情况。重新授权并保存更改可解决此问题。

错误消息 解决方法
无法生成授权令牌。 请重新尝试授权并再次保存更改。

过时页面错误

当用户浏览网页时,如果有人在此浏览器会话之外更改了配置(通过其他浏览器窗口或由其他用户更改配置),而前一用户尚未刷新相应网页,就会出现过时页面错误。以下是您可能看到的相关错误:

错误消息 解决方法
您的页面过旧。配置设置已存在。 请刷新以覆盖现有设置。
您的页面过旧。配置设置不存在。 请刷新以覆盖现有设置。
您的页面过旧。无法激活未配置的配置设置。 请刷新以覆盖现有设置。
您的页面过旧。无法删除未配置的配置设置。 请刷新以覆盖现有设置。

 

暂时性页面错误

这些错误是暂时的,一般过段时间后刷新页面或重新执行相应操作即可解决。

错误消息 解决方法
无法提取配置设置 请刷新页面。
无法提取配置预设值 请刷新页面。
无法提取配置状态 请刷新页面。
配置激活失败 请重新尝试激活配置。
删除配置设置时出错 请重新尝试删除配置。
无法创建配置设置 请重新创建配置设置并保存更改。
无法更新配置设置 请重新更新配置设置并保存更改。
无法提取自定义属性 请重新尝试保存自定义属性。
无法更新属性映射 请重新更新您的属性映射。
无法更新自动配置的群组设置 请重新更新您的群组设置。
无法更新取消配置设置 请重新更新您的取消配置设置。
已成功删除配置,但无法撤消 API 客户端访问权限。

删除配置时,我们会撤消应用访问您 Google 方数据的权限。

如果此操作由于某个原因失败,请访问安全部分下方的“管理 API 客户端访问权限”,手动撤消访问权限。

如果您删除配置后还要重新设置,则无需采取任何操作。 

更新配置设置时出错 请刷新页面。
身份验证失败 在配置中提供的身份验证凭据(例如不记名令牌)有误。请输入正确的凭据。
提供的 SCIM 端点网址无效 提供的目标端点无效。请输入正确的网址。
启用配置时出错 请将自动配置滑块移动到活跃
删除配置设置时出错
  1. 点击自动配置以打开“设置”。
  2. 删除配置下方,点击删除
无法从目标服务提供商处提取属性
  1. 点击自动配置以打开“设置”。
  2. 属性映射下方,点击修改
  3. 根据需要修改服务提供商映射。
无法提取您的目标资源架构 请验证设置自动配置时提供的端点网址,然后重新尝试将云目录属性映射到目标应用属性。

自动配置运行时失败

自动配置运行时失败可能是由于 API 访问、授权或配置相关问题导致的。

Google 内部服务错误

错误代码 说明和解决方法
17003
17006
17008

说明:

无法通过 Google 内部服务进行身份验证。

原因:

以下用户配置客户端 ID 的权限已被撤消:

910835873219-es01p47a1ks618hgp59q26cnc6sv33r3.apps.googleusercontent.com

解决方法

请确保此 ID 有以下范围的权限:

https://www.googleapis.com/auth/admin.directory.user.readonly
https://www.googleapis.com/auth/admin.directory.userschema.readonly
https://www.googleapis.com/auth/admin.directory.group.member.readonly

在管理控制台中,使用安全高级设置下方的“管理 API 客户端访问权限”来验证客户端 ID 包含这些范围,或将这些范围添加到此客户端 ID。

17007

说明:

无法使用全网域授权向支持自动配置的应用授予访问权限。

无法为自动配置服务授予全网域权限。此授权至关重要,自动配置服务需要此授权才能读取 Google 目录。

原因:

原因 1:撤消了用户配置客户端 ID 的权限。

解决方法:

在管理控制台中,使用安全 > 高级设置下方的“管理 API 客户端访问权限”来添加以下客户端 ID 和范围:

客户端 ID:
910835873219-es01p47a1ks618hgp59q26cnc6sv33r3.apps.googleusercontent.com

范围:

https://www.googleapis.com/auth/admin.directory.user.readonly
https://www.googleapis.com/auth/admin.directory.userschema.readonly
https://www.googleapis.com/auth/admin.directory.group.member.readonly

另一种解决方法是删除相关应用,然后重新添加。

原因 2:系统意外错误

解决方法:

在大多数情况下,此错误会自动解决。但是,如果此问题在数小时后仍然存在,那么请按上文“原因 1”中所述,添加相应客户端 ID 和范围,或删除并重新添加相应的应用。

身份验证令牌错误

错误代码 说明和原因 解决方法
17010

凭据不足,无法调用您的 SCIM 端点。

原因:身份验证令牌被撤消。

请按以下方式尝试重新授权:点击自动配置以打开“设置”,然后点击重新授权
17013

从您的服务提供商处提取访问令牌时出错。

原因:身份验证令牌被撤消。

如果此错误在一段时间后没有自动解决,请按以下方式尝试重新授权:点击自动配置以打开“设置”,然后点击重新授权

访问令牌错误

错误代码 说明和原因 解决方法
17002
17011

无法生成访问令牌。

原因:某些 Google 内部服务目前不可用。

此问题在一段时间后会自动解决。
17009 无法通过刷新令牌生成访问令牌。 请按以下方式尝试重新授权:点击自动配置以打开“设置”,然后点击重新授权

一般错误

错误代码 说明和原因 解决方法
1200x

内部错误

此问题在一段时间后会自动解决。
25001 Google 后端/服务暂时不可用。 请再次设置自动配置。
25002

Google 后端/服务暂时不可用。

原因:尚未为客户安装应用。

请安装应用,然后再次设置自动配置。
25005 Google 后端/服务暂时不可用。 此问题在一段时间后会自动解决。
25016 Google 后端/服务暂时不可用。 请再次设置自动配置。
50001 内部错误 此问题在一段时间后会自动解决。
50003 内部错误 此问题在一段时间后会自动解决。
50005 已删除的群组出现在已配置的群组过滤器中。 将已删除的群组从配置范围设置中移除。
50006 内部错误 此问题在一段时间后会自动解决。

资源层级失败

如果 SAML 应用设置页面上的“自动配置”部分显示失败,请点击下载列表。下载的文件会列出失败的创建、删除或更新操作,以及每个失败事件的错误代码和说明。

这些错误仅会影响文件中的指定资源。

错误代码 错误说明 解决方法
45003

基于 SCIM 的应用不接受更新、创建和删除资源的请求。请在下载的错误文件中查看错误的详细信息。

可能的原因:

  1. 超出许可限制 - 您的许可只能在基于 SCIM 的应用上创建 5 位用户,但您为 6 位用户启用了自动配置。
  2. 值过长 - 您的值(如电子邮件 ID)过长,基于 SCIM 的应用不接受。
  3. 必须至少有一个权限,其中一个必须是个人资料 ID。
  4. 用户名已存在。用户名在整个单位中必须是独一无二的。
  5. 服务提供商 (SP) 处找不到资源(用户)。
  6. SCIM 用户 ID 值无效。
请更正错误并在保存更改后重试。
45004

服务提供商和 Google(作为身份提供商)之间发生错误。错误消息为“内部错误 - 已超出配额”。

可能的原因:

  • 发生了影响服务提供商的服务中断。
  • 服务提供商的服务器断开。
请与服务提供商联系。
45005 您配置的 SCIM 端点无法访问。请检查您在管理控制台中提供的 SCIM 端点。 请更正错误并在保存更改后重试。
45006

无法正确建立更新、创建和删除资源的请求,或基于 SCIM 的应用不接受这些请求。请在下载的错误文件中查看错误的详细信息。

可能的原因:

  1. 值过长
  2. 许可数量不足
  3. 许可无效
  4. 权限值不存在
请更正错误并在保存更改后重试。
45016

基于 SCIM 的应用拒绝更新、创建和删除资源的请求,因为您没有填写必填字段。请在下载的错误文件中查看错误的详细信息。

请更正错误并在保存更改后重试。

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