Просмотр ошибок автосинхронизации пользователей

При настройке синхронизации пользователей могут возникать следующие ошибки:

Ниже описано, как их устранить.

Если с помощью этих инструкций устранить ошибку не удается, обратитесь в службу поддержки.

Ошибки этапа настройки

Описанные ниже ошибки связаны с настройкой синхронизации пользователей и появляются в консоли администратора.

Ошибка кода авторизации

Такая ошибка может появиться, если код авторизации не удалось заменить на токен обновления. Причиной может послужить неправильный код авторизации или длительный промежуток времени с момента авторизации до нажатия кнопки Сохранить изменения. Чтобы устранить эту ошибку, повторите авторизацию и сохраните изменения.

Сообщение об ошибке Решение
Не удалось сгенерировать токен авторизации. Повторите попытку и сохраните изменения.

Ошибка устаревшей страницы

Эта ошибка возникает, если страница браузера не обновлялась, в то время как настройки были изменены в другом окне браузера или другим пользователем. При этом появляются следующие сообщения:

Сообщение об ошибке Решение
Данные на странице устарели. Конфигурация синхронизации настроена. Чтобы переопределить существующие настройки, обновите страницу.
Данные на странице устарели. Конфигурация синхронизации отсутствует. Чтобы переопределить существующие настройки, обновите страницу.
Данные на странице устарели. Активировать ненастроенную конфигурацию синхронизации нельзя. Чтобы переопределить существующие настройки, обновите страницу.
Данные на странице устарели. Удалить ненастроенную конфигурацию синхронизации нельзя. Чтобы переопределить существующие настройки, обновите страницу.

 

Временная ошибка страницы

Временная ошибка обычно устраняется сама собой. Повторите попытку немного позже. Встречаются следующие ошибки:

Сообщение об ошибке Решение
Не удалось загрузить настройки синхронизации.  Обновите страницу. 
Не удалось загрузить предварительные настройки синхронизации. Обновите страницу. 
Не удалось загрузить статус синхронизации. Обновите страницу.
Не удалось активировать синхронизацию. Повторите попытку.
Не удалось удалить настройки синхронизации. Повторите попытку.
Не удалось создать настройку синхронизации. Повторите попытку и сохраните изменения.
Не удалось обновить настройку синхронизации. Повторите попытку и сохраните изменения.
Не удалось загрузить настраиваемые атрибуты. Повторите попытку.
Не удалось обновить сопоставление атрибутов. Повторите попытку.
Не удалось обновить настройки группы для автосинхронизации. Повторите попытку.
Не удалось обновить конфигурацию отключения. Повторите попытку.
Конфигурация удалена, но запретить доступ клиента API не удалось.

При удалении конфигурации отменяются разрешения, которые позволяют приложению обращаться к вашим данным в сервисах Google.

Эту ошибку можно устранить вручную: нажмите Управлять доступом клиента API в разделе Безопасность.

Если вы планируете позже восстановить конфигурацию, ничего не делайте. 

Не удалось обновить настройки синхронизации. Обновите страницу. 
Ошибка аутентификации Учетные данные для аутентификации (например, токен владельца) указаны неверно. Задайте правильные учетные данные.
Введенный вами URL конечной точки системы кросс-доменного управления учетными данными (SCIM) недействителен. URL конечной точки недействителен. Введите правильный URL.
Не удалось включить синхронизацию. Нажмите Разрешить синхронизацию
Не удалось удалить настройки синхронизации. Нажмите Удалить синхронизацию
Не удалось загрузить атрибуты целевого поставщика услуг. Обновите страницу Сопоставление атрибутов.
Не удалось загрузить набор атрибутов целевого ресурса. Проверьте конечную точку SCIM в процессе настройки синхронизации и повторите сопоставление атрибутов облачного каталога с атрибутами целевого приложения.

Ошибки времени выполнения

Примечание. Сведения в этом разделе приведены для ситуации, когда текущий статус синхронизации пользователей указывает на ошибку.


Ошибки времени выполнения возникают из-за проблем в параметрах конфигурации.


Ниже перечислены коды и описания возможных ошибок, а также способы их устранения.

Ошибки внутренних сервисов Google

Код ошибки Описание и решение
17003

Описание 

Не удалось пройти аутентификацию во внутренних сервисах Google.

Причина

Аннулированы разрешения у следующего идентификатора клиента синхронизации пользователей:

910835873219-es01p47a1ks618hgp59q26cnc6sv33r3.apps.googleusercontent.com

Решение 

Убедитесь, что у данного идентификатора есть разрешения на доступ к следующим областям:

https://www.googleapis.com/auth/admin.directory.user.readonly,
https://www.googleapis.com/auth/admin.directory.userschema.readonly,
https://www.googleapis.com/auth/admin.directory.group.member.readonly

Нажмите Управлять доступом клиента API в разделе Безопасность и перейдите в Расширенные настройки. Проверьте доступ идентификатора к указанным областям и при необходимости добавьте их.

17006

Описание 

Не удалось пройти аутентификацию во внутренних сервисах Google.

Причина

Аннулированы разрешения у следующего идентификатора клиента синхронизации пользователей:

910835873219-es01p47a1ks618hgp59q26cnc6sv33r3.apps.googleusercontent.com

Решение 

Убедитесь, что у данного идентификатора есть разрешения на доступ к следующим областям:

https://www.googleapis.com/auth/admin.directory.user.readonly,
https://www.googleapis.com/auth/admin.directory.userschema.readonly,
https://www.googleapis.com/auth/admin.directory.group.member.readonly

Нажмите Управлять доступом клиента API в разделе Безопасность и перейдите в Расширенные настройки. Проверьте доступ идентификатора к указанным областям и при необходимости добавьте их.

17008

Описание 

Не удалось пройти аутентификацию во внутренних сервисах Google.

Причина

Аннулированы разрешения у следующего идентификатора клиента синхронизации пользователей:

910835873219-es01p47a1ks618hgp59q26cnc6sv33r3.apps.googleusercontent.com

Решение 

Убедитесь, что у данного идентификатора есть разрешения на доступ к следующим областям:

https://www.googleapis.com/auth/admin.directory.user.readonly,
https://www.googleapis.com/auth/admin.directory.userschema.readonly,
https://www.googleapis.com/auth/admin.directory.group.member.readonly

Нажмите Управлять доступом клиента API в разделе Безопасность и перейдите в Расширенные настройки. Проверьте доступ идентификатора к указанным областям и при необходимости добавьте их.

Ошибки токена авторизации

Код ошибки Описание и причина Решение
17010

Недостаточно учетных данных для вызова конечной точки SCIM.

Причина: токен авторизации аннулирован.

Повторите попытку, нажав Авторизовать приложение повторно.
17013

Ошибка получения токена доступа у поставщика услуг.

Причина: токен авторизации аннулирован.

Если эта ошибка не будет автоматически устранена через некоторое время, повторите попытку, нажав Авторизовать приложение повторно.

Ошибки доступа к токену

Код ошибки Описание и причина Решение
17002/17007/17011

Не удалось создать токен доступа.

Причина: сейчас некоторые внутренние сервисы Google недоступны.

Проблема устранится автоматически.
17009 Не удалось создать токен доступа из токена обновления. Повторите попытку, нажав Авторизовать приложение повторно.

Общие ошибки

Код ошибки Описание и причина Решение
1200x

Внутренняя ошибка.

Проблема устранится автоматически.
25001 Сервер или сервис Google временно недоступны. Настройте автосинхронизацию ещё раз.
25002

Сервер или сервис Google временно недоступны. 

Причина: у клиента не установлено приложение.

Установите приложение и настройте автосинхронизацию ещё раз.
25005 Сервер или сервис Google временно недоступны. Проблема устранится автоматически.
25016 Сервер или сервис Google временно недоступны. Настройте автосинхронизацию ещё раз.
50001 Внутренняя ошибка. Проблема устранится автоматически.
50003 Внутренняя ошибка. Проблема устранится автоматически.
50005 Удаленная группа присутствует в фильтрах групп. Удалите данную группу из области синхронизации.
50006 Внутренняя ошибка. Проблема устранится автоматически. 

Ошибки уровня ресурсов

Сведения в этом разделе приведены для ситуации, когда в качестве ошибки синхронизации выдается число.
Это число является ссылкой на файл, содержащий подробную информацию об ошибке. Он содержит код и описание ошибки для каждого ресурса, который не был создан, удален или обновлен во время синхронизации.
Ошибки уровня ресурсов влияют только на конкретные ресурсы в файле. Суть проблемы описана в файле, который можно скачать.

Ниже перечислены коды и описания ошибок, содержащихся в файле, а также способы их устранения.

Код ошибки Описание ошибки Решение
45003

Приложение на базе системы кросс-доменного управления учетными данными (SCIM) не принимает запрос на обновление, создание или удаление ресурса. Подробное описание ошибки содержится в файле, который можно скачать.

Возможные причины:

  1. Превышено максимальное количество лицензий. В приложении на базе SCIM можно создать 5 пользователей, а вы включили синхронизацию для 6 пользователей.
  2. Слишком длинное значение. Например, идентификатор сообщения содержит слишком много символов, поэтому приложение его не принимает.
  3. Необходимо иметь хотя бы одно разрешение, и одним из них должен быть идентификатор профиля.
  4. Имя пользователя уже существует. Оно должно быть уникальным в масштабах организации.
  5. Ресурс (пользователь) не найден на стороне поставщика.
  6. Недопустимое значение идентификатора пользователя SCIM.
После устранения ошибки сохраните изменения и повторите попытку.
45005 Конечная точка системы кросс-доменного управления учетными данными (SCIM) недоступна. Проверьте данные в консоли администратора. После устранения ошибки сохраните изменения и повторите попытку.
45006

Приложение на базе системы кросс-доменного управления учетными данными (SCIM) не принимает запрос на обновление, создание или удаление ресурса. Подробное описание ошибки содержится в файле, который можно скачать.

Возможные причины:

  1. слишком длинное значение;
  2. недостаточно лицензий;
  3. недействительная лицензия;
  4. значение для данного разрешения не существует.
После устранения ошибки сохраните изменения и повторите попытку.
45016

Приложение на базе системы кросс-доменного управления учетными данными (SCIM) не принимает запрос на обновление, создание или удаление ресурса, поскольку обязательное поле не заполнено. Подробное описание ошибки содержится в файле, который можно скачать.

После устранения ошибки сохраните изменения и повторите попытку.
Эта информация оказалась полезной?
Как можно улучшить эту статью?