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Ver erros de provisionamento automático

Ao configurar o provisionamento automático para seus apps baseados em SAML, você poderá ver estes erros:

Veja abaixo como depurar e resolver esses erros.

Observação: se não for possível resolver uma falha seguindo estas etapas, ligue para o suporte.

Falhas no tempo de configuração

Erro de código de autorização

Este erro será exibido quando não for possível trocar o código de autorização por um token de atualização. Isso pode acontecer se o código de autorização estiver incorreto ou se você esperar demais para clicar em Salvar alterações após a autorização. Para resolver esse erro, basta autorizar novamente e salvar as alterações.

Mensagem de erro Resolução
Não foi possível gerar o token de autorização. Tente fazer a autorização novamente e salve as alterações.

Erro de página desatualizada

Os erros de página desatualizada ocorrem quando a página do navegador do usuário não foi atualizada e a configuração foi alterada fora dessa sessão do navegador, em uma janela diferente do navegador ou por um usuário diferente. Estes são os erros associados que talvez sejam exibidos:

Mensagem de erro Resolução
Sua página está desatualizada. A configuração de provisionamento existe. Atualize a página para modificar a configuração existente.
Sua página está desatualizada. A configuração de provisionamento não existe. Atualize a página para modificar a configuração existente.
Sua página está desatualizada. Não é possível ativar uma configuração de provisionamento não definida. Atualize a página para modificar a configuração existente.
Sua página está desatualizada. Não é possível excluir uma configuração de provisionamento não definida. Atualize a página para modificar a configuração existente.

 

Erro de página temporário

Estes erros temporários geralmente são resolvidos quando você atualiza a página ou repete a ação depois de algum tempo.

Mensagem de erro Resolução
Não foi possível buscar a configuração de provisionamento Atualize a página.
Não foi possível buscar a pré-configuração do provisionamento Atualize a página.
Não foi possível buscar o status de provisionamento Atualize a página.
Falha na ativação do provisionamento Tente ativar o provisionamento novamente.
Ocorreu um erro ao excluir a configuração de provisionamento Tente excluir a configuração novamente.
Não foi possível criar a configuração de provisionamento Crie sua configuração de provisionamento novamente e salve as alterações.
Não foi possível atualizar a configuração de provisionamento Atualize sua configuração de provisionamento novamente e salve as alterações.
Não foi possível buscar os atributos personalizados Tente salvar os atributos personalizados novamente.
Não foi possível atualizar o mapeamento de atributos Atualize seu mapeamento de atributos novamente.
Não foi possível atualizar as configurações de grupo para o provisionamento automático Atualize as configurações de grupo novamente.
Não foi possível atualizar a configuração de desprovisionamento Atualize a configuração de desprovisionamento novamente.
A configuração foi excluída, mas não foi possível revogar o acesso do cliente à API

Ao excluir a configuração, revogamos as permissões para os apps acessarem seus dados no Google.

Se isso falhar por algum motivo, revogue o acesso manualmente usando a opção Gerenciar acesso de cliente de API da seção Segurança.

Se você excluiu a configuração e pretende defini-la novamente, não precisa fazer nada.

Erro ao atualizar a configuração de provisionamento Atualize a página.
Falha na autenticação. As credenciais de autenticação (por exemplo, o token do portador) fornecidas na configuração estão incorretas. Digite as credenciais corretas.
O URL do endpoint SCIM fornecido é inválido O endpoint de destino fornecido era inválido. Digite o URL correto.
Ocorreu um erro ao ativar o provisionamento Mova o controle deslizante Provisionamento automático para Ativo.
Ocorreu um erro ao excluir a configuração de provisionamento
  1. Clique em Provisionamento automático para abrir "Configurações".
  2. Em Excluir configuração, clique em Excluir.
Não foi possível buscar atributos do provedor de serviços de destino
  1. Clique em Provisionamento automático para abrir "Configurações".
  2. Em Mapeamento de atributos, clique em Editar.
  3. Edite os mapeamentos do provedor de serviços conforme necessário.
Não foi possível buscar o esquema do recurso de destino Verifique o URL do endpoint informado durante a configuração do provisionamento de usuários e tente mapear os atributos do Cloud Directory para os do app de destino novamente.

Falhas no tempo de execução do provisionamento automático

Estas falhas podem ocorrer devido a problemas de acesso, autorização ou configuração da API.

Erros de serviços internos do Google

Código do erro Descrição e resolução
17003
17006
17008

Descrição:

Não foi possível autenticar com os serviços internos do Google.

Motivo:

As permissões foram revogadas para este ID do cliente de provisionamento de usuários:

910835873219-es01p47a1ks618hgp59q26cnc6sv33r3.apps.googleusercontent.com

Resolução:

Verifique se o código tem permissões para os seguintes escopos:

https://www.googleapis.com/auth/admin.directory.user.readonly,
https://www.googleapis.com/auth/admin.directory.userschema.readonly,
https://www.googleapis.com/auth/admin.directory.group.member.readonly

No Admin Console, use Gerenciar acesso de cliente de API em Segurança e Configurações avançadas para verificar se o ID do cliente tem esses escopos ou adicioná-los ao ID do cliente.

17007

Descrição:

Não foi possível conceder acesso a apps que permitem o provisionamento automático usando a autoridade de delegação em todo o domínio.

Não foi possível conceder autoridade de delegação em todo o domínio ao serviço de provisionamento automático. Isso é fundamental para que o serviço de provisionamento automático leia o diretório do Google.

Motivos:

Motivo 1: as permissões foram revogadas no ID do cliente de provisionamento de usuários.

Solução:

No Admin Console, use Gerenciar acesso de cliente de API em Segurança Configurações avançadas para adicionar os escopos e o ID do cliente abaixo:

ID do cliente:
910835873219-es01p47a1ks618hgp59q26cnc6sv33r3.apps.googleusercontent.com

Escopos:

https://www.googleapis.com/auth/admin.directory.user.readonly,
https://www.googleapis.com/auth/admin.directory.userschema.readonly,
https://www.googleapis.com/auth/admin.directory.group.member.readonly

Uma alternativa é excluir o app e adicioná-lo novamente.

Motivo 2: ocorreram erros inesperados no sistema.

Resolução:

Na maioria dos casos, este erro é resolvido automaticamente. Se o problema persistir depois de algumas horas, adicione o ID do cliente e os escopos ou exclua e adicione novamente o app, conforme mencionado no motivo 1.

Erros do token de autenticação

Código do erro Descrição e motivo Resolução
17010

As credenciais são insuficientes para fazer chamadas para o endpoint SCIM.

Motivo: o token de autenticação foi revogado.

Tente autorizar novamente clicando em Provisionamento automático para abrir "Configurações" e depois em Autorizar novamente.
17013

Ocorreu um erro ao buscar um token de acesso do seu provedor de serviços.

Motivo: o token de autenticação foi revogado.

Se esse erro não for resolvido automaticamente depois de algum tempo, clique em Provisionamento automático para abrir as configurações e então em Reautorizar.

Acessar erros de token

Código do erro Descrição e motivo Resolução
17002
17011

Não foi possível gerar um token de acesso.

Motivo: alguns serviços internos do Google não estão disponíveis no momento.

Este erro costuma ser resolvido automaticamente após algum tempo.
17009 Falha na geração do token de acesso a partir do token de atualização. Tente autorizar novamente clicando em Provisionamento automático para abrir "Configurações" e depois em Autorizar novamente.

Erros gerais

Código do erro Descrição e motivo Resolução
1200x

Erro interno

Este erro costuma ser resolvido automaticamente após algum tempo.
25001 O back-end/serviço do Google está temporariamente indisponível. Configure o provisionamento automático novamente.
25002

O back-end/serviço do Google está temporariamente indisponível.

Motivo: o app não foi instalado para o cliente.

Instale o app e configure o provisionamento automático novamente.
25005 O back-end/serviço do Google está temporariamente indisponível. Este erro costuma ser resolvido automaticamente após algum tempo.
25016 O back-end/serviço do Google está temporariamente indisponível. Configure o provisionamento automático novamente.
50001 Erro interno Este erro costuma ser resolvido automaticamente após algum tempo.
50003 Erro interno Este erro costuma ser resolvido automaticamente após algum tempo.
50005 Um grupo excluído está presente nos filtros do grupo configurado. Remova o grupo excluído da configuração do escopo de provisionamento.
50006 Erro interno Este erro costuma ser resolvido automaticamente após algum tempo.

Falhas no nível do recurso

Caso a seção "Provisionamento automático" da página de configurações do app SAML exiba Falhas, clique em Fazer download da lista.O arquivo lista as ações de criação, exclusão ou atualização que apresentaram falha, além do código do erro e de uma descrição de cada falha.

Esses erros afetam apenas os recursos especificados no arquivo.

Código do erro Descrição do erro Resolução
45003

A solicitação de atualização, criação ou exclusão de recursos não foi aceita pelo seu aplicativo baseado em SCIM. Analise os detalhes do erro no arquivo de erro transferido por download.

Motivos possíveis:

  1. Limite de licenças excedido: você tem licenças para criar apenas cinco usuários no seu app baseado em SCIM e ativou o provisionamento automático para seis usuários.
  2. Valor muito longo: um valor, por exemplo, o ID de e-mail, é muito longo e não é aceito para seu app baseado em SCIM.
  3. É necessário haver pelo menos um direito, sendo que um deles precisa ser o ID do perfil.
  4. O nome de usuário já existe. Ele precisa ser único em toda a organização.
  5. O recurso (usuário) não foi encontrado no lado do provedor de serviço (SP, na sigla em inglês).
  6. O valor do ID de usuário SCIM é inválido.
Corrija o erro e tente novamente após salvar as alterações.
45004

Ocorreu um erro entre o provedor de serviços e o Google como provedor de identidade. O texto de erro é "Erro interno: cota excedida".

Motivos possíveis:

  • Uma falha temporária que afeta o provedor de serviços.
  • O servidor do provedor de serviços está inativo.
Entre em contato com o provedor de serviços.
45005 O endpoint SCIM que você configurou está inacessível. Verifique o endpoint SCIM que você informou no Admin Console. Corrija o erro e tente novamente após salvar as alterações.
45006

A solicitação de atualização, criação ou exclusão do recurso não foi criada corretamente ou não foi aceita pelo aplicativo baseado em SCIM. Analise os detalhes do erro no arquivo de erro transferido por download.

Motivos possíveis:

  1. Valor muito longo
  2. Licenças insuficientes
  3. Licença inválida
  4. O valor de direito não existe
Corrija o erro e tente novamente após salvar as alterações.
45016

A solicitação de atualização, criação ou exclusão de recursos não foi aceita pelo seu aplicativo baseado em SCIM porque você não preencheu um campo obrigatório. Analise os detalhes do erro no arquivo de erro transferido por download.

Corrija o erro e tente novamente após salvar as alterações.

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